Bug 197684 - ldd -r prints unresolved symbols
ldd -r prints unresolved symbols
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-05 11:00 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: net-snmp-5.3.1.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 05:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch, apply on 64bit archs only (1016 bytes, patch)
2006-07-07 10:52 EDT, Karsten Hopp
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2006-07-05 11:00:50 EDT
Description of problem:
net-snmp-libs-5.3.1.pre3-2.x86_64
# ldd -r ./usr/lib64/libsnmp.so.10.0.1
undefined symbol: EVP_DigestInit        (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_DigestFinal       (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_DigestFinal_ex    (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: AES_set_encrypt_key   (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_md5       (./usr/lib64/libsnmp.so.10.0.1)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaaad89000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
undefined symbol: HMAC  (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_MD_CTX_cleanup    (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: SSLeay        (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_sha1      (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_MD_CTX_init       (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: EVP_DigestUpdate      (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: RAND_bytes    (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: DES_cbc_encrypt       (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: DES_ncbc_encrypt      (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: DES_key_sched (./usr/lib64/libsnmp.so.10.0.1)
undefined symbol: AES_cfb128_encrypt    (./usr/lib64/libsnmp.so.10.0.1)
                
The ldd -r output should list  libcrypto.so.6 => /lib64/libcrypto.so.6
instead of undefined symbols.
Comment 1 Karsten Hopp 2006-07-07 10:52:06 EDT
Created attachment 132058 [details]
Proposed patch, apply on 64bit archs only
Comment 2 Radek Vokal 2006-07-10 03:13:14 EDT
Can you please retest with net-snmp-5.3.1.rc4 from rawhide? I guess the issue is
fixed there. 
Comment 3 Karsten Hopp 2006-07-10 04:42:25 EDT
No, net-snmp-5.3.1.rc4 has the same problems, tested on x86_64

btw: using -rpath (in my patch) isn't the best solution, maybe you can find a
better one
Comment 4 Radek Vokal 2006-08-09 08:43:11 EDT
Sorry, by I still can't reproduce this issue 

[root@vepro SPECS]# ldd -r /usr/lib64/libnetsnmp.so.10.0.1 
        libcrypto.so.6 => /lib64/libcrypto.so.6 (0x00002aaaaad87000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaaafd1000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab31e000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaab523000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
[root@vepro SPECS]# rpm -q net-snmp
net-snmp-5.3.1.0-2
[root@vepro SPECS]# uname -a
Linux vepro 2.6.16-1.2111_FC5 

Can you point me to a machine where I can see this bug?
Comment 5 Radek Vokal 2006-08-11 05:34:35 EDT
I believe this is fixed in net-snmp-5.3.1.0-3

Note You need to log in before you can comment on or make changes to this bug.