Bug 197695 - add a frontend to the kexec-tools
add a frontend to the kexec-tools
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
: Reopened
Depends On: 182938
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-05 11:54 EDT by Don Zickus
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 09:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the infrastructure patches (4.53 KB, patch)
2006-07-05 11:56 EDT, Don Zickus
no flags Details | Diff
used to copy the core dump image to the correct location (4.82 KB, patch)
2006-07-05 12:00 EDT, Don Zickus
no flags Details | Diff
builds the kcp.c file and installs it in the right location (985 bytes, patch)
2006-07-05 12:02 EDT, Don Zickus
no flags Details | Diff
the default config file (1.08 KB, patch)
2006-07-05 12:04 EDT, Don Zickus
no flags Details | Diff
this script generates the initrd file for the kdump facility (33.78 KB, patch)
2006-07-05 12:10 EDT, Don Zickus
no flags Details | Diff
patch to build the kcp binary (709 bytes, patch)
2006-07-19 11:28 EDT, Don Zickus
no flags Details | Diff

  None (edit)
Description Don Zickus 2006-07-05 11:54:22 EDT
Description of problem:
The kexec-tools does not have a configurable frontend to mimic what netdump and
diskdump used.  The attached patches add that functionality.

What these patches do is add functionality to do all the kernel core capturing
inside the initrd (as opposed to relying on the disk).  When building the initrd
file, the kdump.conf is consulted to determine where to place the resulting
kernel core image and an appropriate image is created.  To do this correctly, th
e mkinitrd tools had to support a new command and I had to create numerous new
files.  Simplicity was the aim here, however the problem has always been complex
so my goal may take a few iterations to achieve.  

These patches have been baking for awhile with only a few people testing them
and providing feedback (mainly IBM).  I have posted them to the kexec-tools
mailing list numerous times.  Perhaps these patches are very stable! ;)  

I would like to see inclusion of them in our package to allow for more broader
testing.  Hopefully, these patches will help ween customers off diskdump and
netdump.  

NOTE: backwards compatibility is preserved if noone initially configures the
/etc/kdump.conf file (which is to just mount the disk and save the file there).
This allows users to upgrade and not see any ill-effects.
Comment 1 Don Zickus 2006-07-05 11:56:37 EDT
Created attachment 131939 [details]
the infrastructure patches

This patch modifies the build infrastructure to handle the new files correctly.
Comment 2 Don Zickus 2006-07-05 12:00:58 EDT
Created attachment 131941 [details]
used to copy the core dump image to the correct location

Due to limitations in the grubby application, in order to properly copy kernel
core image to timestamped locations, one needs to do this inside an app.
Comment 3 Don Zickus 2006-07-05 12:02:10 EDT
Created attachment 131942 [details]
builds the kcp.c file and installs it in the right location
Comment 4 Don Zickus 2006-07-05 12:04:03 EDT
Created attachment 131943 [details]
the default config file
Comment 5 Don Zickus 2006-07-05 12:10:40 EDT
Created attachment 131944 [details]
this script generates the initrd file for the kdump facility


This is basically a copy/paste job of mkinitrd with additional stuff oriented
towards kdump.	The additional stuff constitutes less than 5% of the whole
file.  I don't know the best way to maintain this (and possibly keep in synch
with mkinitrd).  Peter Jones suggested he would make a library to I could use
to include here (and to be used by mkinitrd).  This would make things easier. 
However, he has been busy and hasn't gotten around to it.  

For now I submit this file as whole (knowing it is it pain to review my
changes) until someone has a better idea).
Comment 6 Neil Horman 2006-07-17 11:27:58 EDT
your infrastructure patch add a 
Patch502: kexec-tools-1.101-Makefile-kcp.patch
Yet, I see no such patch attached here?  Can you attach it please?
Thanks
Comment 7 Don Zickus 2006-07-19 11:28:47 EDT
Created attachment 132692 [details]
patch to build the kcp binary

Sorry about that.  Lost in the list of files..
Comment 8 Neil Horman 2006-07-19 23:35:50 EDT
checked in.  Thanks!
Comment 9 Don Zickus 2006-07-26 16:36:41 EDT
The first attached patch has changes to kdump.init that never got applied.  :(
Comment 10 Neil Horman 2006-07-27 09:27:11 EDT
Sorry about that Don.  It appears I had the kdump.init patched in to a version
of the file living on a different branch.  Not sure how it missed my merge. 
Anyway, its in there now, checked in and built for FC6

Note You need to log in before you can comment on or make changes to this bug.