Bug 197702 - mkinitrd is not creating the appropriate root mount point resulting in a /dev/root kernel panic
Summary: mkinitrd is not creating the appropriate root mount point resulting in a /dev...
Status: CLOSED DUPLICATE of bug 197701
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-05 16:37 UTC by Brian Wright
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 15:16:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Wright 2006-07-05 16:37:09 UTC
Description of problem:
mkinitrd is not creating the appropriate root mount location, resulting in 
a /dev/root kernel panic

Version-Release number of selected component (if applicable):
Current release

How reproducible:
Install a kernel rpm or compile a custom kernel and then run mkinitrd for the 
given kernel.  The kernel rpm install does the mkinitrd automatically

Steps to Reproduce:
1. Compile the kernel and copy bzImage to /boot/vzlinux-2.6.17.3
2. mkinitrd initrd-2.6.xx.x 2.6.17.3
3. Reboot the system.  A Kernel panic is generated because /dev/root can't be 
mounted to /sysroot
  
Actual results:
init has "mount /sysroot"

Expected results:
init should have "mount -o defaults --ro -t ext3 /dev/hdc2 /sysroot"

Additional info: Please see the attached text file, it was posted to the fedora-
users list and gives more information on this issue.  I currently have to hand 
edit the init file to change "mount /sysroot" to "mount -o defaults --ro -t 
ext3 /dev/hdc2 /sysroot

Comment 1 Peter Jones 2006-07-13 15:16:22 UTC

*** This bug has been marked as a duplicate of 197701 ***


Note You need to log in before you can comment on or make changes to this bug.