Bug 1977313 - condor fails to build with Sphinx 4.0.2
Summary: condor fails to build with Sphinx 4.0.2
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: condor
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Theisen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1967078 1992884 (view as bug list)
Depends On:
Blocks: F35FTBFS F36FTBFS, RAWHIDEFTBFS F36FailsToInstall, RAWHIDEFailsToInstall PYTHON3.10 1973718
TreeView+ depends on / blocked
 
Reported: 2021-06-29 12:56 UTC by Karolina Surma
Modified: 2021-08-24 13:44 UTC (History)
12 users (show)

Fixed In Version: condor-8.8.15-1.fc35, condor-8.8.15-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-24 13:44:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Karolina Surma 2021-06-29 12:56:45 UTC
condor fails to build with Sphinx 4.0.2 in Fedora 35 (currently Rawhide).

+ make -C docs man
make: Entering directory '/builddir/build/BUILD/htcondor-8_8_10/docs'
sphinx-build -b man -d _build/doctrees   . _build/man
Running Sphinx v4.0.2
WARNING: while setting up extension index: role 'index' is already registered, it will be overridden
making output directory... done
Exception occurred:
  File "/builddir/build/BUILD/htcondor-8_8_10/docs/conf.py", line 452, in setup
    app.add_stylesheet('css/htcondor-manual.css')
AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'

For the logs from testing build attempts, see:
https://copr.fedorainfracloud.org/coprs/ksurma/pygments-2.9.0/package/condor/

Possible solution for this issue:
In some cases it may be enough to replace the call to 'add_stylesheet' with 'add_css_file' instead.


You can test you package using Koji scratch build
koji build --scratch <srpm>


For details regarding the Sphinx change, see https://fedoraproject.org/wiki/Changes/Sphinx4
Let us know here if you have any questions. Thank you!

Comment 1 Tim Theisen 2021-06-29 15:48:05 UTC
This is a problem with the included documentation for the Jupyter notebooks. The solution is to patch the documentation to point directly to the tutorials. Unfortunately, then this section of the manual is no longer available off-line. After patching this today, we will work on getting the python notebook documentation back into the manual.

Comment 2 Miro Hrončok 2021-07-26 09:04:41 UTC
*** Bug 1967078 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2021-08-10 13:09:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 4 Miro Hrončok 2021-08-23 11:13:27 UTC
(In reply to Tim Theisen from comment #1)
> This is a problem with the included documentation for the Jupyter notebooks.
> The solution is to patch the documentation to point directly to the
> tutorials. Unfortunately, then this section of the manual is no longer
> available off-line. After patching this today, we will work on getting the
> python notebook documentation back into the manual.

Hey Tim. Any update on this? Can we at least temporarily disable the documentation build to make python3-condor installable again?

Comment 5 Tim Theisen 2021-08-23 15:44:21 UTC
Hello Miro,

I push an update today.

Thank you for your patience.

...Tim

Comment 6 Tim Theisen 2021-08-24 04:41:46 UTC
*** Bug 1992884 has been marked as a duplicate of this bug. ***

Comment 7 Miro Hrončok 2021-08-24 10:27:23 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Comment 8 Miro Hrončok 2021-08-24 12:02:32 UTC
This was only built on F35, could you also build in Rawhide?

Comment 9 Tim Theisen 2021-08-24 13:28:24 UTC
I have built for rawhide as well. Can this be closed now?

Comment 10 Miro Hrončok 2021-08-24 13:44:48 UTC
Yes, thank you!


Note You need to log in before you can comment on or make changes to this bug.