This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 197741 - man page conflict with bsd-games
man page conflict with bsd-games
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
:
Depends On:
Blocks: 197465
  Show dependency treegraph
 
Reported: 2006-07-05 17:45 EDT by Wart
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.00-16.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 12:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2006-07-05 17:45:28 EDT
Description of problem:
xscreensaver-extras installs a man page named worm.6, which conflicts with the
worm.6 manpage provided by the bsd-games package in Extras (BZ #197465).

Version-Release number of selected component (if applicable):
xscreensaver-extras-5.00-10.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install xscreensaver-extras
2. Install bsd-games
3. Look at the contents of the worm.6 man page

Additional info:
I notice that there was a similar problem when the xscreensaver man pages were
in section 1 (BZ #166441).  Perhaps the screensaver man pages can be moved to
section 1x or section 6x to avoid both of these conflicts?
Comment 1 Mamoru TASAKA 2006-07-11 12:47:52 EDT
Hello, Wart:
I noticed this issue today by the previous 
mail titled "File conflicts in FE".

Currently, xscreensaver in devel is not FC but FE.
The assignee of xscreensaver-5.00-13.fc6 (now) is not Ray but me.

Please change the assignee and the product of this bug correctly so that
I can follow this bug.
Comment 2 Wart 2006-07-11 12:52:38 EDT
I've reassigned the bug to you and changed the Product field to FE.
Comment 3 Mamoru TASAKA 2006-07-11 13:52:08 EDT
Jamie, how do you think of this issue?
Comment 4 Wart 2006-08-10 19:18:50 EDT
ping.  Have you given any more thought on this?  I'd like to resolve this bug
before FC6 is released.
Comment 5 Mamoru TASAKA 2006-08-10 19:38:25 EDT
Well, I have not decided how to deal with this yet.

In fact, there was a large amount of discussion as of
in what entry the man pages of xscreensaver should belong to
before releasing FC5 (at this time, xscreensaver was in core)
and we concluded that they should be in "6" (games).

Currently, man pages of FC5-xscreensaver is in "1", which is
actually A BUG , a bug report against this (i.e. man entry of
FC5-xscreensaver should be in "6") already exists, 
however, Ray won't fix this any longer because
he is very busy maintaining other packages.

So, I don't want to move the entry of man pages from "6".
"6x" is not suitable I think because usually "x" means
this is related to X Window system or Tk.

Umm... I can simply remove worm.6 man pages, however, I don't want
this of course. There is always possibility that xscreensaver man pages
conflict with others because xscreensaver has MANY man pages......
Comment 6 Wart 2006-08-10 19:46:50 EDT
(In reply to comment #5)
> So, I don't want to move the entry of man pages from "6".
> "6x" is not suitable I think because usually "x" means
> this is related to X Window system or Tk.

I suggested '6x' mostly because xscreensaver is in fact an X-based application.
 I agree that using section '6' seems to be the most logical place, and putting
it in '6x' means, to me at least, that these are x-based applications that can
be grouped with games.

The worms application from bsd-games, however, is a text-based game, not an
X-based screensaver.  In my opinion, it makes more sense for 'worms.6' to refer
to this game and not a screensaver, thus my suggestion to use '6x' as the next
best place for the screensaver manpages.

> Umm... I can simply remove worm.6 man pages, however, I don't want
> this of course. There is always possibility that xscreensaver man pages
> conflict with others because xscreensaver has MANY man pages......

I understand.  I expect that we'll see more and more of these types of conflicts
as the number of packages in FE grows.  Packages such as xscreensaver and
bsd-games are more likely to be affected based on the number of applications
they place in /usr/bin and the number of man pages they create.
Comment 7 Mamoru TASAKA 2006-08-10 20:30:03 EDT
Well:

https://www.redhat.com/archives/fedora-extras-commits/2006-August/msg00797.html

Job queued as 14021.
Comment 8 Mamoru TASAKA 2006-08-10 21:03:54 EDT
Okay, man entries in extras and gl-extras are moved to "6x"
in xscreensaver-5.00-16.fc6. Please verify these packages if
these resolves this issue.
Comment 9 Mamoru TASAKA 2006-08-13 12:34:52 EDT
Closing as "resolved RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.