Bug 1977509 - F35FailsToInstall: python3-fasjson-client+cli
Summary: F35FailsToInstall: python3-fasjson-client+cli
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fasjson-client
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1989021 (view as bug list)
Depends On:
Blocks: F35FailsToInstall F35BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-06-29 23:45 UTC by Miro Hrončok
Modified: 2021-09-07 19:06 UTC (History)
3 users (show)

Fixed In Version: python-fasjson-client-1.0.1-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-07 19:06:39 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-29 23:45:10 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (python-fasjson-client) Fails To Install in Fedora 35:

can't install python3-fasjson-client+cli:
  - nothing provides (python3.10dist(click) < 8 with python3.10dist(click) >= 6.7) needed by python3-fasjson-client+cli-0.1.2-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-30 00:11:32 UTC
Here is my proposed solution: https://src.fedoraproject.org/rpms/python-fasjson-client/pull-request/1

Comment 2 Miro Hrončok 2021-07-07 11:43:50 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Miro Hrončok 2021-08-02 09:32:53 UTC
*** Bug 1989021 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-08-02 10:12:02 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Ben Cotton 2021-08-10 13:09:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 6 Nils Philippsen 2021-09-01 07:30:51 UTC
Oops, missed that one. Sorry.

Comment 7 Fedora Update System 2021-09-01 10:00:22 UTC
FEDORA-2021-d3dd5253d2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d3dd5253d2

Comment 8 Miro Hrončok 2021-09-01 10:17:38 UTC
Requesting a Beta Freeze Exception as the package does not even install without the fix.

Comment 9 Fedora Update System 2021-09-01 19:26:45 UTC
FEDORA-2021-d3dd5253d2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d3dd5253d2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d3dd5253d2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Miro Hrončok 2021-09-02 09:31:15 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 11 Adam Williamson 2021-09-06 15:08:53 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/423 , marking accepted.

Comment 12 Fedora Update System 2021-09-07 19:06:39 UTC
FEDORA-2021-d3dd5253d2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.