Bug 1977510 - F35FailsToInstall: python3-molecule
Summary: F35FailsToInstall: python3-molecule
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-molecule
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: chedi toueiti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1989023 (view as bug list)
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-06-29 23:45 UTC by Miro Hrončok
Modified: 2021-09-24 20:13 UTC (History)
4 users (show)

Fixed In Version: python-molecule-3.4.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-24 20:13:36 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-29 23:45:12 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-molecule) Fails To Install in Fedora 35:

can't install python3-molecule:
  - nothing provides python3dist(click) < 8.0 needed by python3-molecule-3.2.4-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-07-07 11:43:55 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2021-08-02 10:08:47 UTC
*** Bug 1989023 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2021-08-02 10:12:08 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Ben Cotton 2021-08-10 13:10:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 5 Laurent Wandrebeck 2021-08-26 11:09:45 UTC
Hello,

I hit the same too:

[lwandrebeck@localhost ~]$ uname -a
Linux localhost.localdomain 5.14.0-0.rc6.46.fc35.x86_64 #1 SMP Mon Aug 16 20:02:52 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
[lwandrebeck@localhost ~]$ cat /etc/redhat-release 
Fedora release 35 (Thirty Five)
[lwandrebeck@localhost ~]$ LANG=C sudo dnf install python3-molecule
Last metadata expiration check: 1:19:52 ago on Tue Aug 24 09:09:31 2021.
Error: 
 Problem: conflicting requests
  - nothing provides python3dist(click) < 8.0 needed by python3-molecule-3.2.4-2.fc35.noarch
(try to add '--skip-broken' to skip uninstallable packages)

What kind of additional info do you need ?

Thanks,
Laurent.

Comment 6 Fedora Update System 2021-09-01 14:44:13 UTC
FEDORA-2021-65ec3cd4be has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-65ec3cd4be

Comment 7 Fedora Update System 2021-09-01 19:27:38 UTC
FEDORA-2021-65ec3cd4be has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-65ec3cd4be`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-65ec3cd4be

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Miro Hrončok 2021-09-02 09:31:15 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 9 Miro Hrončok 2021-09-02 09:34:50 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/python-molecule by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 10 Fedora Update System 2021-09-24 20:13:36 UTC
FEDORA-2021-65ec3cd4be has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.