Bug 1977511 - F35FailsToInstall: python3-shamir-mnemonic
Summary: F35FailsToInstall: python3-shamir-mnemonic
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-shamir-mnemonic
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonny Heggheim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1989025 (view as bug list)
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-06-29 23:45 UTC by Miro Hrončok
Modified: 2021-08-03 10:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-03 10:44:03 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-29 23:45:14 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (python-shamir-mnemonic) Fails To Install in Fedora 35:

can't install python3-shamir-mnemonic:
  - nothing provides (python3.10dist(click) < 8 with python3.10dist(click) >= 7) needed by python3-shamir-mnemonic-0.2.1-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-07-07 11:44:00 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2021-08-02 10:08:50 UTC
*** Bug 1989025 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2021-08-02 10:12:15 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Jonny Heggheim 2021-08-02 16:49:26 UTC
Building now https://koji.fedoraproject.org/koji/taskinfo?taskID=73155227

Comment 5 Jonny Heggheim 2021-08-02 16:50:09 UTC
Seems like version 8 of click that is included in Fedora 35 works out of the box https://github.com/trezor/python-shamir-mnemonic/issues/38

Comment 6 Miro Hrončok 2021-08-03 10:44:03 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.