Bug 1977689 - Download backup disk command failes in sdk/examples/backup_vm.py
Summary: Download backup disk command failes in sdk/examples/backup_vm.py
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.4.7.5
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.4.8
: ---
Assignee: Eyal Shenitzky
QA Contact: Amit Sharir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-30 09:48 UTC by sshmulev
Modified: 2021-08-19 06:23 UTC (History)
9 users (show)

Fixed In Version: python-ovirt-engine-sdk4-4.4.14
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-19 06:23:04 UTC
oVirt Team: Storage
pm-rhel: ovirt-4.4+
michal.skrivanek: blocker-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115335 0 None MERGED backup_vm.py: fix download backup disk command 2021-06-30 11:31:55 UTC

Description sshmulev 2021-06-30 09:48:47 UTC
Download backup disk command failed in sdk/examples/backup_vm.py


Description of problem:
Download backup disk command fails after starting a backup.


Version-Release number of selected component (if applicable):
vdsm-4.40.70.5-1.el8ev.x86_64
ovirt-engine 4.4.7.5-0.9.el8ev
python3-ovirt-engine-sdk4-4.4.13-1.el8ev.x86_64


How reproducible:
100%

Steps to Reproduce:

1) Start a backup on a disk
2) Run this command to download the backup disk in the host: python3 /usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py -c engine download 23f1b05d-3a4d-4a2e-8765-c61e883923c0 --backup-dir . --backup-uuid 1cc771a6-3d5b-4fca-a922-614d59bf103f

Actual results:
The action failes with this error:

python3 /usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py -c engine download 23f1b05d-3a4d-4a2e-8765-c61e883923c0 --backup-dir . --backup-uuid 1cc771a6-3d5b-4fca-a922-614d59bf103f
[   0.0 ] Downloading VM '23f1b05d-3a4d-4a2e-8765-c61e883923c0' disks
Traceback (most recent call last):
  File "/usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py", line 493, in <module>
    main()
  File "/usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py", line 176, in main
    args.command(args)
  File "/usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py", line 249, in cmd_download
    connection, args.backup_uuid, args, incremental=args.incremental)
  File "/usr/share/doc/python3-ovirt-engine-sdk4/examples/backup_vm.py", line 359, in download_backup
    if not args.download_backup:
AttributeError: 'Namespace' object has no attribute 'download_backup'

Comment 1 Avihai 2021-07-04 09:16:15 UTC
The issue is fixed but the fix patch is only in master(upstream) but not in current RHV 4.4.7-6 (which is 4.4.7 RC/ python3-ovirt-engine-sdk4-4.4.13-1)
@Eyal can someone assist as this is breaking a lot of Tier2 automation test cases and considered automation blocker for QE.

Comment 3 RHEL Program Management 2021-07-05 07:31:20 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 4 Martin Perina 2021-07-12 04:49:12 UTC
The fix is merged and it will be included in upcoming Python SDK release for oVirt 4.4.8

Comment 6 Amit Sharir 2021-07-25 15:00:08 UTC
Version: 
vdsm-4.40.80.2-1.el8ev.x86_64
ovirt-engine-4.4.8.1-0.9.el8ev.noarch
python3-ovirt-engine-sdk4-4.4.14-1.el8ev.x86_64


Verification conclusions:
The expected output matched the actual output.
The total flow mentioned was done with no errors/unexpected logs.
I was able to download the backup disk using the sdk/examples/backup_vm.py command.  


Bug verified.

Comment 7 Sandro Bonazzola 2021-08-19 06:23:04 UTC
This bugzilla is included in oVirt 4.4.8 release, published on August 19th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.8 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.