Bug 197776 - Realplayer doesn't like x86-64
Realplayer doesn't like x86-64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: realplayer (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-07-06 05:19 EDT by Bastien Nocera
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 15:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-07-06 05:19:45 EDT
RealPlayer-10.0.7-2.i386

When playing a Wave file, or an MP3, Realplayer x86 (there's no native x86-64
version) crashes with a SIGFPE. The backtrace (without many symbols) looks like:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread 1082169248 (LWP 18299)]
0x40ba4fa6 in CloseEngine () from ./common/clntcore.so
(gdb) bt
#0  0x40ba4fa6 in CloseEngine () from ./common/clntcore.so
#1  0x40b6bea7 in CloseEngine () from ./common/clntcore.so
#2  0x40ab69a9 in CloseEngine () from ./common/clntcore.so
#3  0x40abb8c6 in CloseEngine () from ./common/clntcore.so
#4  0x40a65623 in CloseEngine () from ./common/clntcore.so
#5  0x40a6700f in CloseEngine () from ./common/clntcore.so
#6  0x40a6f3c1 in CloseEngine () from ./common/clntcore.so
#7  0x40b2e6c9 in CloseEngine () from ./common/clntcore.so
#8  0x40bab2f0 in CloseEngine () from ./common/clntcore.so
#9  0x40ba250b in CloseEngine () from ./common/clntcore.so
#10 0x40b49f3a in CloseEngine () from ./common/clntcore.so
#11 0x40b49ba3 in CloseEngine () from ./common/clntcore.so
#12 0x40b4a905 in CloseEngine () from ./common/clntcore.so
#13 0x40b4a982 in CloseEngine () from ./common/clntcore.so
#14 0x40a60b73 in CloseEngine () from ./common/clntcore.so
#15 0x0809ce96 in getopt ()
#16 0x0809c7c3 in getopt ()
#17 0x08094eac in ?? ()
#18 0x00000000 in ?? ()

The bug has also been filed upstream:
https://bugs.helixcommunity.org/show_bug.cgi?id=5035
Comment 2 RHEL Product and Program Management 2006-09-05 15:34:33 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 3 RHEL Product and Program Management 2006-09-05 15:47:21 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.