This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 197779 - Amarok crashs on exit and might be rebuild against latest qt
Amarok crashs on exit and might be rebuild against latest qt
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 06:48 EDT by Florian Sievert
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 08:59:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backtrace of amarok on exit. (13.47 KB, application/octet-stream)
2006-07-06 06:48 EDT, Florian Sievert
no flags Details
Backtrace of amarok on exit with version 1.4.1 (13.47 KB, application/octet-stream)
2006-07-10 01:56 EDT, Florian Sievert
no flags Details

  None (edit)
Description Florian Sievert 2006-07-06 06:48:44 EDT
Description of problem:
Since the latest qt-update Amarok crashs on exit. Downgrading on the
3.3.6-0.1.fc5 qt packages seems to solve the problem. Amarok might needs to be
rebuild against latest qt/kde.


Version-Release number of selected component (if applicable):
Qt: 3.3.6
KDE: 3.5.3-0.2.fc5 Red Hat
amaroK: 1.4.0

How reproducible:
Always

Steps to Reproduce:
1. Start Amarok
2. Exit Amarok
  
Actual results:
Amarok crashes with the attached error message.

Expected results:
Amarok exits without any problem.

Additional info:
Problem was reproducible on two different systems. A third person using
KDE-RedHat was not able to reproduce this problem:
amarok-1.4.0-5.fc5
qt-3.3.6-6.1.fc5.kde
kdelibs-3.5.3-4.1.fc5.kde
Comment 1 Florian Sievert 2006-07-06 06:48:45 EDT
Created attachment 131992 [details]
Backtrace of amarok on exit.
Comment 2 Aurelien Bompard 2006-07-07 17:05:09 EDT
I am currently in the process of updating amarok to 1.4.1. I'll keep you informed.
Comment 3 Florian Sievert 2006-07-10 01:56:43 EDT
Created attachment 132161 [details]
Backtrace of amarok on exit with version 1.4.1

I just made the update to 1.4.1, however the problem seems to still exist.
After exit, it takes about 10 minutes, then the xine engine seems to play
shortly the rest of the buffer and KMail is opened for crash report again. I ll
attached the back trace of the new version again and will try to compile the
new amarok version on my system as well within the next days.
Comment 4 Florian Sievert 2006-07-11 18:31:45 EDT
Compiling amarok 1.4.1 on my system results in exactly the same behaviour. I
tried to change the backend engine from xine to helix and the crash did also
happen. If you downgrade to qt-3.3.6-0.1.fc5 (and relatated packages of this
version) everything works fine. Looks like the problem is not related to amarok
itself, but to the new qt release.
Comment 5 Florian Sievert 2006-07-13 08:59:14 EDT
Today the qt-packages 3.3.6-0.4.fc5 are avaible via yum and after installing
them, the problem with amarok is gone. Seems like the problem is fixed.
=> WFM

Note You need to log in before you can comment on or make changes to this bug.