Bug 197781 - Exception occurred: system-config-network cannot save changes
Summary: Exception occurred: system-config-network cannot save changes
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-06 11:47 UTC by Elin Svensson
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-10-02 14:00:35 UTC


Attachments (Terms of Use)
The crash dump (2.18 KB, text/plain)
2006-07-06 11:47 UTC, Elin Svensson
no flags Details
The file /etc/ppp/chap-secrets (232 bytes, text/plain)
2006-10-02 08:55 UTC, Elin Svensson
no flags Details
The file /etc/ppp/pap-secrets (231 bytes, text/plain)
2006-10-02 08:56 UTC, Elin Svensson
no flags Details
The new chap-secrets file. (154 bytes, text/plain)
2006-10-02 13:54 UTC, Elin Svensson
no flags Details

Description Elin Svensson 2006-07-06 11:47:42 UTC
Created attachment 131993 [details]
The crash dump

Comment 1 Elin Svensson 2006-07-06 11:47:42 UTC
Description of problem:
Exception occurred when trying to save changes made in system-config-network

Version-Release number of selected component (if applicable):
1.3.30

How reproducible:
Always

Steps to Reproduce:
1. Start system-config-network
2. Change something
3. Save
  
Actual results:
Exception occurred and a crash dump


Expected results:
That the changes would be saved.


Additional info:
System-config-network worked earlier, but has now stopped working. I changed
eth0 to eth1(nVidia...) and eth1 to eth0(Marvell...) saved and planned to push
"shut down" and choose reboot. Accidently I pushed "suspend" instead. The screen
went black and did not react on the keyboard or the mouse. I turned the computer
off and rebooted. Now the network connection was gone and the files
/etc/sysconfig/network, /etc/sysconfig/network-scripts/ifcfg-eth0,
/etc/sysconfig/network-scripts/ifcfg-eth1 and /eth/hosts were corrupt. They
contained mainly a lot of strange symbols. System-config-network could not save
and could open the devices to do any changes but it was possible to see that it
now said that eth0 was eth0(nVidia...) and eth1 was eth1(Marvell...). After
editing the corrupted files manually the network connection is working again,
but system-config-network crashes when saving and asks for a bug report.

Could there be more corrupt files that causes system-config-network to behave
like this? After my manual editing it is at least possible to open the devices
for editing, so corrupt files seem to be a problem for system-config-network.

Comment 2 Harald Hoyer 2006-09-29 12:00:44 UTC
errr.. please check /etc/ppp/pap-secrets and /etc/ppp/chap-secrets

Comment 3 Elin Svensson 2006-10-02 08:55:18 UTC
Created attachment 137526 [details]
The file  /etc/ppp/chap-secrets

Here is the file /etc/ppp/chap-secrets

Comment 4 Elin Svensson 2006-10-02 08:56:50 UTC
Created attachment 137527 [details]
The file /etc/ppp/pap-secrets

Here is the file etc/ppp/pap-secrets

Comment 5 Harald Hoyer 2006-10-02 13:21:38 UTC
hmm... cannot read them..

Comment 6 Harald Hoyer 2006-10-02 13:23:55 UTC
I think they are broken... you may remove them, if you have no data
(whatformatever) in them

Comment 7 Elin Svensson 2006-10-02 13:54:31 UTC
Created attachment 137543 [details]
The new chap-secrets file.

I removed chap-secrets and pap-secrets, and now system-config-network can save
changes again. The two new files that were created when I tried saving look
like the one I have attached, and they are readable. The main problem seem to
solved - I just have to avoid pushing "suspend" in the future, since it appears
to be dangerous... Thank you for finding the corrupt files!


Note You need to log in before you can comment on or make changes to this bug.