Bug 197781 - Exception occurred: system-config-network cannot save changes
Exception occurred: system-config-network cannot save changes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 07:47 EDT by Elin Svensson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 10:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The crash dump (2.18 KB, text/plain)
2006-07-06 07:47 EDT, Elin Svensson
no flags Details
The file /etc/ppp/chap-secrets (232 bytes, text/plain)
2006-10-02 04:55 EDT, Elin Svensson
no flags Details
The file /etc/ppp/pap-secrets (231 bytes, text/plain)
2006-10-02 04:56 EDT, Elin Svensson
no flags Details
The new chap-secrets file. (154 bytes, text/plain)
2006-10-02 09:54 EDT, Elin Svensson
no flags Details

  None (edit)
Description Elin Svensson 2006-07-06 07:47:42 EDT
Created attachment 131993 [details]
The crash dump
Comment 1 Elin Svensson 2006-07-06 07:47:42 EDT
Description of problem:
Exception occurred when trying to save changes made in system-config-network

Version-Release number of selected component (if applicable):
1.3.30

How reproducible:
Always

Steps to Reproduce:
1. Start system-config-network
2. Change something
3. Save
  
Actual results:
Exception occurred and a crash dump


Expected results:
That the changes would be saved.


Additional info:
System-config-network worked earlier, but has now stopped working. I changed
eth0 to eth1(nVidia...) and eth1 to eth0(Marvell...) saved and planned to push
"shut down" and choose reboot. Accidently I pushed "suspend" instead. The screen
went black and did not react on the keyboard or the mouse. I turned the computer
off and rebooted. Now the network connection was gone and the files
/etc/sysconfig/network, /etc/sysconfig/network-scripts/ifcfg-eth0,
/etc/sysconfig/network-scripts/ifcfg-eth1 and /eth/hosts were corrupt. They
contained mainly a lot of strange symbols. System-config-network could not save
and could open the devices to do any changes but it was possible to see that it
now said that eth0 was eth0(nVidia...) and eth1 was eth1(Marvell...). After
editing the corrupted files manually the network connection is working again,
but system-config-network crashes when saving and asks for a bug report.

Could there be more corrupt files that causes system-config-network to behave
like this? After my manual editing it is at least possible to open the devices
for editing, so corrupt files seem to be a problem for system-config-network.
Comment 2 Harald Hoyer 2006-09-29 08:00:44 EDT
errr.. please check /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
Comment 3 Elin Svensson 2006-10-02 04:55:18 EDT
Created attachment 137526 [details]
The file  /etc/ppp/chap-secrets

Here is the file /etc/ppp/chap-secrets
Comment 4 Elin Svensson 2006-10-02 04:56:50 EDT
Created attachment 137527 [details]
The file /etc/ppp/pap-secrets

Here is the file etc/ppp/pap-secrets
Comment 5 Harald Hoyer 2006-10-02 09:21:38 EDT
hmm... cannot read them..
Comment 6 Harald Hoyer 2006-10-02 09:23:55 EDT
I think they are broken... you may remove them, if you have no data
(whatformatever) in them
Comment 7 Elin Svensson 2006-10-02 09:54:31 EDT
Created attachment 137543 [details]
The new chap-secrets file.

I removed chap-secrets and pap-secrets, and now system-config-network can save
changes again. The two new files that were created when I tried saving look
like the one I have attached, and they are readable. The main problem seem to
solved - I just have to avoid pushing "suspend" in the future, since it appears
to be dangerous... Thank you for finding the corrupt files!

Note You need to log in before you can comment on or make changes to this bug.