Bug 197795 - sk98lin module is missing from kernel-smp-2.6.17-*_FC4
sk98lin module is missing from kernel-smp-2.6.17-*_FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 09:47 EDT by Ed Young
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 21:08:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Young 2006-07-06 09:47:45 EDT
Description of problem:
The sk98lin module is missing from the two latest kernel releases.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.17-1.2139_FC4
kernel-smp-2.6.17-1.2141_FC4


How reproducible:
Absolutely reproducible - it's missing in action.

Steps to Reproduce:
1. cd /lib/modules
2. find . -name 'sk*'
3. verify it just isn't there.
  
Actual results:
(/lib/modules)
# find . -name 'sk*'
./2.6.16-1.2111_FC4smp/kernel/drivers/net/sk98lin
./2.6.16-1.2111_FC4smp/kernel/drivers/net/sk98lin/sk98lin.ko
./2.6.16-1.2111_FC4smp/kernel/drivers/net/skfp
./2.6.16-1.2111_FC4smp/kernel/drivers/net/skfp/skfp.ko
./2.6.16-1.2111_FC4smp/kernel/drivers/net/sky2.ko
./2.6.16-1.2111_FC4smp/kernel/drivers/net/skge.ko
./2.6.16-1.2111_FC4smp/kernel/drivers/net/tokenring/skisa.ko
./2.6.17-1.2139_FC4smp/kernel/drivers/net/skfp
./2.6.17-1.2139_FC4smp/kernel/drivers/net/skfp/skfp.ko
./2.6.17-1.2139_FC4smp/kernel/drivers/net/sky2.ko
./2.6.17-1.2139_FC4smp/kernel/drivers/net/skge.ko
./2.6.17-1.2141_FC4smp/kernel/drivers/net/skfp
./2.6.17-1.2141_FC4smp/kernel/drivers/net/skfp/skfp.ko
./2.6.17-1.2141_FC4smp/kernel/drivers/net/sky2.ko
./2.6.17-1.2141_FC4smp/kernel/drivers/net/skge.ko


Expected results:
I expected to find sk98lin directories and files in:
  2.6.17-1.2139_FC4smp/kernel/drivers/net
  2.6.17-1.2141_FC4smp/kernel/drivers/net

Additional info:
As expected, my eth1 is failing.
Comment 1 Jarod Wilson 2006-07-06 10:15:16 EDT
The skge and sky2 drivers replace the sk98lin driver, so I'd give them a try.
Comment 2 JP Matos 2006-07-07 18:07:35 EDT
Trying to reconfigure the network interface with system-config-network it
complains about the missing sk98lin and no skge or sky2 are suggested.
Comment 3 Richard Körber 2006-07-19 02:46:14 EDT
In /etc/modprobe.conf, changing the line "alias eth0 sk98lin" to "alias eth0
skge" did the trick for me.

Strange enough, one FC5 machine of mine did the change automatically, while
another FC5 machine had to be changed manually.
Comment 4 Ed Young 2006-07-19 21:08:13 EDT
I made the changes suggested by Richard Körber:

In /etc/modprobe.conf:
  changing the line "alias eth0 sk98lin" 
  to "alias eth0 skge"

Did indeed do the trick.  This is no longr a problem.
Comment 5 Richard Körber 2006-07-20 07:30:56 EDT
I made a mistake about the machines. The machine that needed to be changed
manually, is actually running FC4 (not FC5 as I stated in comment #3). So it
seems to be an issue with FC4 only.
Comment 6 JP Matos 2006-07-20 07:43:35 EDT
Resolution as NOTABUG seems to be a gross overstatement. I guess FC4 is going to
legacy any day now... WONTFIX maybe?

Note You need to log in before you can comment on or make changes to this bug.