Bug 1977982 - Kernel version in /etc/driver-toolkit-release.json not including architecture
Summary: Kernel version in /etc/driver-toolkit-release.json not including architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Special Resource Operator
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.8.z
Assignee: dagray
QA Contact: Lena Horsley
URL:
Whiteboard:
Depends On: 1977972
Blocks: 1985546
TreeView+ depends on / blocked
 
Reported: 2021-06-30 20:29 UTC by OpenShift BugZilla Robot
Modified: 2021-08-03 06:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-03 06:09:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift driver-toolkit pull 45 0 None open [release-4.8] Bug 1977982: /etc/driver-toolkit-release.json kernel version match rpm -q output 2021-06-30 20:30:03 UTC
Red Hat Product Errata RHBA-2021:2896 0 None None None 2021-08-03 06:10:11 UTC

Description OpenShift BugZilla Robot 2021-06-30 20:29:50 UTC
+++ This bug was initially created as a clone of Bug #1977972 +++

In versions of OCP where ART is specifying the kernel version as an argument to the driver-toolkit image build, the KERNEL_VERSION and RT_KERNEL_VERSION in /etc/driver-toolkit-release.json is missing the architecture. 

This results in unneeded inconsistencies between OCP versions, and means in some cases the kernel versions do not match with the node labels from NFD.

Comment 3 Lena Horsley 2021-07-27 20:01:14 UTC
Verified in build: 4.8.0-0.nightly-2021-07-26-182557

1. Go to the OpenShift release nightly build page for the nightly build, click "Download the installer," and then click "release.txt."

2. Search for "driver-toolkit" and pull the corresponding image to your dev machine with the command:
podman pull --authfile /path/to/pullsecret <openshift_release_repo>/<corresponding_image_to_your_dev_machine>

3. Enter the following command from the terminal:
podman run <image_from_previous_step> cat /etc/driver-toolkit-release.json

4. Ensure that the kernel version's contain the architecture at the end, for example
4.18.0-305.7.1.el8_4.x86_64 
not
4.18.0-305.7.1.el8_4


=========================================================================================================================================


Output from step #3

{ "KERNEL_VERSION": "4.18.0-305.10.2.el8_4.x86_64", "RT_KERNEL_VERSION": "4.18.0-305.10.2.rt7.83.el8_4.x86_64", "RHEL_VERSION": "8.4" }

Comment 5 errata-xmlrpc 2021-08-03 06:09:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.3 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2896


Note You need to log in before you can comment on or make changes to this bug.