Bug 197834 - "Send Bug Report" does not work
"Send Bug Report" does not work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-07-06 14:10 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 11:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 346797 None None None Never

  None (edit)
Description Matthias Clasen 2006-07-06 14:10:54 EDT
It brings up a bug-buddy error dialog, saying
"Both --pid and --appname arguments are requires"
Comment 1 Matthew Barnes 2006-07-06 15:19:30 EDT
Filed this upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=346797

Now I just need to learn the proper way to invoke bug-buddy these days.
Comment 2 Matthew Barnes 2006-07-07 13:56:23 EDT
Proposed a patch upstream, putting it in Rawhide for testing.

It's unclear whether it's even appropriate to invoke bug-buddy from the menu
item, as bug-buddy is intended to report _crashes_.  I suggested having the menu
item open a web browser to
<http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution>.

In any case, the patch makes the menu item work as it did before.

evolution-2.7.3-9
Comment 3 Matthias Clasen 2006-07-19 20:44:47 EDT
I agree that the current bug-buddy is not suitable for this kind of use
anymore
Comment 4 Matthew Barnes 2006-07-25 17:38:53 EDT
Has this been tested against the new bug-buddy?
I was going to leave this open until it's resolved upstream.
Comment 5 Matthew Barnes 2006-08-11 14:19:48 EDT
Re-opening this bug until upstream reaches a consensus.

I have updated the patch in Rawhide to use the new non-crash mode feature of
bug-buddy 2.15.90, although bug-buddy itself seems pretty flaky right now.
Comment 6 Matthew Barnes 2006-08-18 11:14:28 EDT
Changed my mind.  Closing this as UPSTREAM seems more appropriate.
Comment 7 Christopher Beland 2007-08-28 13:22:45 EDT
In Fedora 7, "Help" -> "Submit a Bug Report" no longer produces an error. 
bug-buddy is successfully started, and appears to have appropriate fields for
submitting a non-crash bug report.

evolution-2.10.3-2.fc7
bug-buddy-2.18.0-2.fc7
Comment 8 Matthew Barnes 2007-08-28 13:34:37 EDT
Thanks for the feedback, Christopher.

Note You need to log in before you can comment on or make changes to this bug.