Bug 197843 - hex boxes in welcome message
hex boxes in welcome message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-07-06 14:39 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 15:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 346918 None None None Never

  None (edit)
Description Matthias Clasen 2006-07-06 14:39:40 EDT
The evolution welcome message contains characters which are rendered
as hex boxes with the default FC font setup.
Comment 1 Simos Xenitellis 2006-07-15 07:05:10 EDT
What numbers are inside the hex boxes?
This will help determine which font is missing or whether the text encoding has
gone wrong.
Comment 2 Matthew Barnes 2006-07-15 09:00:31 EDT
On my Fedora machine I see a [0020] hex box after each bullet in the New
Features section of the message.
Comment 3 Simos Xenitellis 2006-07-15 09:39:00 EDT
0x20 is the space character.

The space character should normally be display ok, as it is encoded the same way
whether it is UTF-8 or latin1 or iso-8859-x.

Most probably the issue arises from the bullet character; my guess would be that
the bullet character is a Unicode character, however there is an encoding issue
in that fragment of Evolution's code.

Can you check with Character Map that 0x25CB or 0x25CF are available in FC6t1?
It appears that the stylesheet of the default e-mail uses those Unicode characters.

I use Ubuntu at the moment and I am able to view those characters as my system
font supports those Unicode ranges.

To be able to rule out evolution encoding problems (because they are unlikely as
in other distros it works), you can try to install the DejaVu fonts and view the
default e-mail again.
See http://fedoraproject.org/wiki/Fonts/DejavuFeedbackCall
for instructions.

The default e-mail is found at 
/usr/share/evolution/2.6/default/C/mail/local/Inbox  (Ubuntu).
Comment 4 Matthias Clasen 2006-07-19 20:55:27 EDT
Hmm, this no longer happens for me in rawhide.

Note You need to log in before you can comment on or make changes to this bug.