Bug 197844 - clean FC5 install to Poweredge 2400 w/ PERC2/DC throws exception after formating /boot directory
Summary: clean FC5 install to Poweredge 2400 w/ PERC2/DC throws exception after format...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL: http://russkiypenguin.livejournal.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-06 18:46 UTC by Daniel J. Doughty
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 00:32:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump from anaconda (91.28 KB, text/plain)
2006-07-06 18:46 UTC, Daniel J. Doughty
no flags Details

Description Daniel J. Doughty 2006-07-06 18:46:05 UTC
Description of problem:

Doing a clean install of FC5 where /(ext)3, /boot(ext3) and SWAP were going to
the first disk of sda.  All other 5 disks were supposed to become a RAID6
software raid.  PERC2/DC is set to MASSSTORAGE.  Just before it starts
installing packages it threw an exception that I've caught on a floppy.


Version-Release number of selected component (if applicable):

FC5

How reproducible:

Attempting second install now.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Install fails, throws exception, then reboots.

Expected results:

Installs cleanly, then reboots.

Additional info:

Comment 1 Daniel J. Doughty 2006-07-06 18:46:05 UTC
Created attachment 132019 [details]
dump from anaconda

Comment 2 Daniel J. Doughty 2006-07-06 19:06:24 UTC
Just reproduced the error.  It formatted all the filesystems, transferred the
image to the hard disk for the install and then throws an exception again.  I've
got a copy of it as well if anyone wants it.

In the Exception details it says

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1253, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 245, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 951, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 156, in doPreInstall
    backend.doPreInstall(intf, id, instPath, dir)
  File "/usr/lib/anaconda/yuminstall.py", line 923, in doPreInstall
    id.fsset.write(instPath)
  File "/usr/lib/anaconda/fsset.py", line 1213, in write
    cf = self.mdadmConf()
  File "/usr/lib/anaconda/fsset.py", line 1202, in mdadmConf
    cf = cf + ent.device.mdadmLine()
  File "/usr/lib/anaconda/fsset.py", line 2029, in mdadmLine
    return "ARRAY %s/%s level=%s num-devices=%d uuid=%s\n" \
IndexError: list index out of range

Comment 3 Jeremy Katz 2006-07-11 00:32:49 UTC
Caused by RAID6 -- fixed in CVS

Comment 4 Daniel J. Doughty 2006-07-11 18:52:59 UTC
I'm new to logging a bug.  So, how would I now try to install this again?  
Install from source RPMs, or download a "test" ISO from 
http://redhat.download.fedoraproject.org/pub/fedora/linux/core/test/5.90/i386/i
so/

I'm fairly experienced at unix, but since this is happening upon install, I'm 
a bit baffled as to how I should continue.  I sure don't want to wait until 
October for the full release of FC6.


Note You need to log in before you can comment on or make changes to this bug.