Bug 197869 - NetworkManager assigns ipv6 addr from documentation prefix 2001:db8
NetworkManager assigns ipv6 addr from documentation prefix 2001:db8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 15:56 EDT by Matt Domsch
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 13:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-07-06 15:56:18 EDT
Description of problem:
NetworkManager in Fedora Core 6 rawhide tree appears to be assigning an IPv6
address to interfaces when no IPv6 router is advertising routes; the assigned
address is from the reserved "documentation" prefix 2001:db8.  For example, this
is a wired ethernet port that's active.  The global address here is from the
docs prefix.

eth0      Link encap:Ethernet  HWaddr 00:12:3F:1A:D9:EB
          inet addr:10.9.71.115  Bcast:10.9.79.255  Mask:255.255.240.0
          inet6 addr: 2001:db8:1:0:212:3fff:fe1a:d9eb/64 Scope:Global
          inet6 addr: fe80::212:3fff:fe1a:d9eb/64 Scope:Link

Stopping NetworkManager and using 'ifdown eth0; ifup eth0' to get an address via
DHCP, this global address is not assigned.  Restarting NM and doing likewise,
the address is assigned again, hence my supposition it's NM's doing.  However, I
can't see easily in the NM code where it could be getting this.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.cvs20060529.1
Comment 1 Dan Williams 2006-07-09 19:32:27 EDT
cc-ing Dave Woodhouse since he did the patch for not clobbering ipv6.  Dave,
what's the next step here?
Comment 2 David Woodhouse 2006-07-10 05:32:27 EDT
I strongly suspect that it isn't NetworkManager at fault here. The only thing
NetworkManager did was make sure it puts back the _link_ address when it brings
the interface up.

When you stop NM and bring it up again with 'ifup', does it have a link-local
address? If not, that's a NetworkManager bug -- it should put them back when it
exits. I suspect that's what's happening, though, and it explains why you don't
pick up the bogus address after using NM. 

I suspect there's something on your network advertising that route. Can you show
output of 'ip -6 addr show dev eth0' and 'ip -6 route' -- and 'tcpdump -i eth0
-l -n icmp6'

Do you _have_ a default route? Where to? What if you echo 0 >
/proc/sys/net/ipv6/conf/eth0/accept_ra
Comment 3 Matt Domsch 2006-07-10 13:50:44 EDT
I can no longer reproduce this.  Two things have changed.
1) this weekend I upgraded many RPMs to rawhide
2) this machine was on another ipv6 capable network over the weekend

As of now, I'm no longer seeing the documentation prefix addresses on this
system.  Closing as such.

Note You need to log in before you can comment on or make changes to this bug.