Bug 197879 - exclude "lustre" and "lustre_lite" filesystems from /etc/updatedb.conf
exclude "lustre" and "lustre_lite" filesystems from /etc/updatedb.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: slocate (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 16:30 EDT by Andreas Dilger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.7-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 16:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Dilger 2006-07-06 16:30:35 EDT
Description of problem:
In systems running the Lustre distributed filesystem, having hundreds or
thousands of node traverse the filesystem due to slocate.cron is unpleasant. 
The upstream slocate maintainer will be excluding the "lustre" and "llite"
filesystem types via the /etc/updatedb.conf PRUNEFS variable, but I hope that
you will also do this.

Additional info:
This is applicable to all RHEL and FC releases to date, so it would be desirable
to fix this in all versions.
Comment 1 Miloslav Trmač 2006-07-08 21:10:34 EDT
AFAICS from the latest sources, "lustre" is a nodev filesystem (and I can't find
any "llite" filesystem registration); if so, nothing needs to be done for the
supported FC releases.  Can you please attach the contents of /proc/filesystems
when all the Lustre filesystem drivers are loaded?

An RHEL slocate update probably won't happen unless there are important bugs that
need to be fixed, or a customer experiences the issue; nevertheless feel free to
clone this bug report against the relevant RHEL releases.
Comment 2 Andreas Dilger 2006-07-18 03:04:40 EDT
You are right in that lustre is registered as a "nodev" filesystem.  And I
mis-typed - I meant to say to exclude the "lustre_lite" filesystem type.

/proc/filesystems
:
:
nodev   lustre_lite
nodev   lustre

Even though Lustre a nodev filesystem, I can't find anywhere that this actually
matters.  I thought at first when you mentioned this "Doh! there must be a
global exclusion for all nodev filesystem types" (which would probably be a good
idea), but I can't see this anywhere in the code (slocate-2.7.22 being the
latest FC version I can find for FC4 and FC5, and nothing in the upstream
slocate-3.1 release either).

I did a little experiment with /etc/cron.daily/slocate.cron, having removed some
of the PRUNEFS excludes in /etc/updatedb.conf (iso9660, shmfs, devpts, sysfs,
this was on FC3 + slocate-2.7.12).  I run slocate.cron, and it indexed files on
/dev/shm (tmpfs), /mnt/cdrom (iso9660), /var/lib/nfs/rpc_pipefs (sunrpc), /sys
(sysfs), /dev/pts (devpts).  So clearly the exclusions in updatedb.conf PRUNEFS
are needed even for nodev filesystems.
Comment 3 Miloslav Trmač 2006-07-19 16:56:07 EDT
Thanks.  FC-4 slocate filters out nodev filesystems in
/etc/cron.daily/slocate.cron.  FC-5 replaces slocate with mlocate, but uses
the same automatic exclusions.

updatedb should therefore do the right thing automatically since FC-4.

Note You need to log in before you can comment on or make changes to this bug.