Bug 197882 - keyboard indicator applet issues
keyboard indicator applet issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On: 196561
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-07-06 16:57 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 21:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-07-06 16:57:22 EDT
a) it has a "Layout" menuitem which brings up an awesome empty window.

b) it has some plugin management gui, but apparently no plugins. I do
not know what need there is for plugins in a keyboard indicator anyway.
Comment 1 Simos Xenitellis 2006-07-15 07:10:46 EDT
These issues have been discussed at the Keyboard discussion, irc log at
http://wiki.freedesktop.org/wiki/KeyboardInputDiscussion

a) Layout should show the current layout (a keyboard with the characters on the
keys). If it does not work, it should be a configuration issue in Fedora

b) Apparently, the Plugins option should be relegated in the dialog box, in a
tab and not be so visible.
In the plugins one can enable functionality such as using flags to display the
current layout. Those plugins are available at gswitchit.sf.net
I think Sergey mentioned he is inclined to move Plugins to a less visible location.

The big issue is (a) however. :)
Comment 2 Matthias Clasen 2006-07-22 10:23:56 EDT
unfortunately, a) was not fixed by moving to xkeyboard-config, so we need
to investigate. 

Regarding the flags, we need to patch the plugin stuff out, since we don't 
ship them anyway.
Comment 3 Matthias Clasen 2006-07-26 12:33:36 EDT
so the layout not being shown is due to XkbGetKeyboard returning NULL.
Comment 4 Kevin E. Martin 2006-07-29 16:10:51 EDT
This sounds like a duplicate of bug #196561, which was an Xkb regression and is
now fixed upstream and in xorg-x11-server-Xorg-1.1.1-14.fc6.i386.rpm.
Comment 5 Matthias Clasen 2006-07-30 11:57:35 EDT
the layout-not-shown part, yes. Keeping this bug open for the kill-the-plugins part.
Comment 6 Matthias Clasen 2006-08-03 21:52:22 EDT
fixed in 2.15.90

Note You need to log in before you can comment on or make changes to this bug.