Bug 197887 - Need alias for MIME type application/x-msexcel
Need alias for MIME type application/x-msexcel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 17:28 EDT by Bill Alexander
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.20-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 07:55:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct the problem (403 bytes, patch)
2006-07-06 17:28 EDT, Bill Alexander
no flags Details | Diff

  None (edit)
Description Bill Alexander 2006-07-06 17:28:09 EDT
Description of problem:

Alias for Microsoft Excel MIME type should be added:

<alias type="application/x-msexcel"/>

Version-Release number of selected component (if applicable):

shared-mime-info-0.17-1.fc5.2

How reproducible:

Always.

; receipt of emails containing Excel spreadsheets from Microsoft-bound
colleagues use this MIME type.  Since there's no entry for it, Gnome can't
figure out what to do with it

Steps to Reproduce:
1.  Colleage sends email containing an Excel spreadsheet with this MIME type.
2.  Evolution fails to recognize what it is (No registered entry).
3.  User is annoyed.  
  
Actual results:

Gnome applications fail to recognize the file type.

Expected results:

Gnome applications should recognize this file type and permit launching of any
appropriately registered applications (i.e. oocalc, or whatever).

Additional info:

Fix is to add an alias:

# diff -Naur freedesktop.org.xml.orig freedesktop.org.xml
--- freedesktop.org.xml.orig    2006-07-06 14:20:16.000000000 -0700
+++ freedesktop.org.xml 2006-07-06 14:19:48.000000000 -0700
@@ -733,6 +733,7 @@
     <glob pattern="*.xlt"/>
     <glob pattern="*.xld"/>
     <alias type="application/msexcel"/>
+    <alias type="application/x-msexcel"/>
   </mime-type>
   <mime-type type="application/vnd.ms-powerpoint">
     <comment>PowerPoint presentation</comment>

This patch works perfectly.
Comment 1 Bill Alexander 2006-07-06 17:28:09 EDT
Created attachment 132026 [details]
Patch to correct the problem
Comment 2 Bastien Nocera 2007-02-01 10:30:34 EST
Good idea, committed upstream:

2007-02-01  Bastien Nocera  <hadess@hadess.net>

        * freedesktop.org.xml.in: Patch from Bill Alexander
        <billtrash@gmail.com> to add application/x-msexcel as an
        alias for Excel files (RH #197887)
Comment 3 Bastien Nocera 2007-02-06 07:55:42 EST
Fixed in shared-mime-info-0.20-1.fc7

Note You need to log in before you can comment on or make changes to this bug.