Bug 197896 - i8kbuttons no longer needs to control volume
i8kbuttons no longer needs to control volume
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: i8kutils (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 18:37 EDT by Jaime Martín Jiménez
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 03:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaime Martín Jiménez 2006-07-06 18:37:28 EDT
Description of problem:

I have a Dell Inspiron 4150 with Fedora Core 5. i8kbuttons daemon doesn't work
because if I prees a Fn+Volume Key ocurrs anything (with i8kbuttons running, of
course). Nevertheless, I can do Dell Inspiron keys working by assing these keys
to volume control in Gnome Preferences. 

If it's posible (Ubuntu Linux do it) Fedora should detect that it's a Dell
Laptop (¿i8k module enabled?) and assign these keys to volume control in Gnome
Preferences.

Version-Release number of selected component (if applicable):


How reproducible:
Always I press Dell volume control keys.

Steps to Reproduce:
1. Press any Dell volume control key
2. Volume doesn't go up or down
3.
  
Actual results:
I8kbuttons daemon doesn't work.

Expected results:
I want control volume in my Dell laptop with keys designed for this.

Additional info:
Comment 1 Matthias Saou 2006-07-07 08:07:35 EDT
You've filed this bug report against the wrong component... i8kutils is useful
for you only because it forces the i8k module to be loaded on your hardware, so
you get access to the Dell service tag and are able to control the laptop fans.
But i8kbuttons isn't useful on your hardware...

So if you want the Fedora Core installer or GNOME to automatically detect
multimedia keys and enable them... it's to be done elsewhere, and I don't even
know if that's possible at all (I doubt it).

Please reassign to the proper component, otherwise I'll go ahead and close this
report.

Currently, what you ask for has to be done "manually" once, by going to "System"
-> "Preferences" -> "Keyboard Shortcuts", but I suppose you probably knew that
already.
Comment 2 Jaime Martín Jiménez 2006-07-07 12:04:20 EDT
Thank you Matthias.

What's the proper component of this bug?

i8kutils init script isn't the problem but i8kbuttons. i8kbuttons doesn't work
for me. To fix it it's the bug reason.

Question about auto-detect Dell Inspiron laptop is secondary. Simply we have to
researched how Ubuntu Gnome do it.
Comment 3 Matthias Saou 2006-07-07 16:27:41 EDT
I was just pointing out that i8kbuttons isn't the "right solution" for your
laptop, it's more of a "hack" for older Dell laptops. What you're requesting
doesn't depend on i8kbuttons or i8kutils in any way, it's a much more generic
feature request that needs to be implemented somewhere else... where exactly, I
don't know.

Maybe a good topic to bring up on the fedora-devel mailing-list.
Comment 4 Jaime Martín Jiménez 2006-07-07 19:04:06 EDT
OK. Detecting multimedia keys is a more generic solution. I was just pointing
out that there is another Linux distribution that solved this bug (only in Gnome
of course).

You can change bug status. I'm going to subscribe fedora-devel mailing list (if
users no-developers can do it of course).
Comment 5 Matthias Saou 2006-07-08 03:29:20 EDT
OK, closing this bug  for now.

Note You need to log in before you can comment on or make changes to this bug.