Bug 1979051 - dracut no longer starting network when using rd.neednet=1
Summary: dracut no longer starting network when using rd.neednet=1
Keywords:
Status: CLOSED DUPLICATE of bug 1976641
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-04 14:27 UTC by Klaas Demter
Modified: 2021-07-14 14:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-14 14:26:46 UTC
Type: Bug


Attachments (Terms of Use)
Working boot debug output (126.53 KB, application/x-xz)
2021-07-04 14:27 UTC, Klaas Demter
no flags Details
Not working boot debug output (129.30 KB, application/x-xz)
2021-07-04 14:27 UTC, Klaas Demter
no flags Details

Description Klaas Demter 2021-07-04 14:27:01 UTC
Created attachment 1797830 [details]
Working boot debug output

Description of problem:
After the update to dracut-055-2 the network is not started anymore even though I am specifying rd.neednet=1, downgrade to dracut-053-4 ; rebuild with dracut -f ; network booting fine again


Version-Release number of selected component (if applicable):
dracut-055-2
fedora 34

How reproducible:
easily reproduceable if you have clevis+tang for root unlocking -- this is why I noticed the problem :)



Steps to Reproduce:
1. echo 'kernel_cmdline="rd.neednet=1"' > /etc/dracut.conf.d/clevis.conf
2. dracut -f
3.

Actual results:
No network during boot

Expected results:
Network during boot


Additional info:

Comment 1 Klaas Demter 2021-07-04 14:27:34 UTC
Created attachment 1797831 [details]
Not working boot debug output

Comment 2 Klaas Demter 2021-07-14 14:09:03 UTC
This is introduced in https://bodhi.fedoraproject.org/updates/FEDORA-2021-5058a47bd9 dracut-054-6.git20210518.fc34
also present in latest version https://bodhi.fedoraproject.org/updates/FEDORA-2021-9d1b72b267 dracut-055-3.fc34

last working version:
https://bodhi.fedoraproject.org/updates/FEDORA-2021-9dd2ebc2a8 dracut-053-5.fc34

Network setup of the VM is nothing special, single interface with dhcp.

Comment 3 Klaas Demter 2021-07-14 14:15:49 UTC
this may be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1976641

Comment 4 Klaas Demter 2021-07-14 14:26:46 UTC

*** This bug has been marked as a duplicate of bug 1976641 ***


Note You need to log in before you can comment on or make changes to this bug.