Bug 197917 - nm-applet crashes upon every logout
nm-applet crashes upon every logout
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-07 08:02 EDT by Leszek Matok
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-09 19:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of gdb nm-applet while logging out of GNOME (3.48 KB, text/plain)
2006-07-07 08:02 EDT, Leszek Matok
no flags Details

  None (edit)
Description Leszek Matok 2006-07-07 08:02:21 EDT
Description of problem:
Every time I log out of GNOME, I see bug-buddy popping up when other windows are
disappearing, telling me nm-applet crashed.

I ran `killall nm-applet;gdb nm-applet` from tty1 with DISPLAY :0.0 and I hope
this crash is the same. I'll attach the output right away.

Version-Release number of selected component (if applicable):
Not sure what is the cause here (and I really don't have time to browse through
the sources):
NetworkManager-gnome-0.6.3-1.fc5
libnotify-0.3.0-6

How reproducible:
always

Steps to Reproduce:
1. Log into GNOME.
2. Log out/shutdown/reboot.
3. See bug-buddy for a moment before X dies.
  

Additional info:
I don't use NetworkManager. It's just there by default and for sure shouldn't
crash. I'd just rpm -e it, but I'll try to help debug it instead for other poor
Fedora users.
Comment 1 Leszek Matok 2006-07-07 08:02:21 EDT
Created attachment 132044 [details]
output of gdb nm-applet while logging out of GNOME
Comment 2 Dan Williams 2006-07-09 19:30:33 EDT
Fixed in CVS HEAD and on 0.6.x branch.

Note You need to log in before you can comment on or make changes to this bug.