Bug 197950 - grhino fails to build in mock with minimal build environment.
Summary: grhino fails to build in mock with minimal build environment.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: grhino   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-BuildReq
TreeView+ depends on / blocked
 
Reported: 2006-07-07 15:50 UTC by Paul Howarth
Modified: 2013-01-10 03:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 04:31:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log with minimal environment (37.59 KB, text/plain)
2006-07-07 15:50 UTC, Paul Howarth
no flags Details
Fix for buildroot traces in omf file (2.03 KB, patch)
2006-10-13 07:42 UTC, Paul Howarth
no flags Details | Diff

Description Paul Howarth 2006-07-07 15:50:14 UTC
This package fails to build in mock if the minimal build group is reduced to
only the packages listed in the Exceptions section of the packaging guidelines.
 build.log is attached.

This problem can be fixed by adding a buildreq of gettext

Comment 1 Paul Howarth 2006-07-07 15:50:14 UTC
Created attachment 132063 [details]
Build log with minimal environment

Comment 2 Matt Domsch 2006-10-12 12:44:26 UTC
Looks like this was attempted to be rebuilt on 9-Oct by the owner, but it failed
due to check-buildroot finding an error.

Comment 3 Michel Alexandre Salim 2006-10-12 23:27:03 UTC
I'm still tracking this down - I did add a buildreq of gettext but that still
does not do the trick, now it's complaining that the ${BUILDROOT} is found in
installed files:

http://buildsys.fedoraproject.org/logs/fedora-development-extras/19406-grhino-0.15.2-2.fc6/

The bizarre thing is that rebuilding on my own machine does not fail. Any idea?
I'm installing mock on my machine to test this, so hopefully it'll be fixed by
the weekend, or I'll downgrade to 0.15.0.

Comment 4 Paul Howarth 2006-10-13 07:42:38 UTC
Created attachment 138405 [details]
Fix for buildroot traces in omf file

> The bizarre thing is that rebuilding on my own machine does not fail. Any
idea?
> I'm installing mock on my machine to test this, so hopefully it'll be fixed
by
> the weekend, or I'll downgrade to 0.15.0.

Do you have rpmdevtools installed? You'll need that to get the buildroot check.


The attached patch has two hunks. The first should fix the rpmlint complaints
about mixed use of spaces and tabs, and the second should cause the omf file to
be reinstalled in a way that does not contain buildroot traces.

Comment 5 Michel Alexandre Salim 2006-10-30 04:31:49 UTC
New RPMs rebuilt and await signing. I decided to fix the Makefile.in so I could
forward the changes to upstream.


Note You need to log in before you can comment on or make changes to this bug.