Bug 197987 - admin.fedoraproject.org SSL certificate certified by unknown authority
admin.fedoraproject.org SSL certificate certified by unknown authority
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: Account System (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-07 17:08 EDT by Hans Ulrich Niedermann
Modified: 2008-03-17 14:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: now
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 14:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2006-07-07 17:08:28 EDT
Description of problem:

  The SSL certificate for admin.fedoraproject.org has been certified by an
  unknown authority (unknown to the Firefox in an updated FC5).

  Step 1 of

    http://fedoraproject.org/wiki/Infrastructure/AccountSystem/CLAHowTo
  
  points the prospective contributor to

    https://admin.fedora.redhat.com/accounts/userbox.cgi

  where one is supposed to submit one's keys.

  This page's certificate is
    a) signed by a CA unknown to FC5's Firefox and
    b) issued to admin.fedoraproject.org, not admin.fedora.redhat.com

Version-Release number of selected component (if applicable):

  2006-07-07 21:10 UTC

How reproducible:

  Every time.

Steps to Reproduce:

  1. Use account on updated FC5.
  2. Start Firefox without any specially added SSL certificates.
  3. Visit https://admin.fedoraproject.org/accounts/userbox.cgi

Actual results:

  Dialog window "Website certified by an Unknown Authority"

Expected results:

  The web form to create a Fedora Account.

Proposed Solution:

  a) Make sure the certificate is signed by a CA which is at least known to
FC5's standard web browser Firefox.
  b) Use canonical links to admin.fedoraproject.org and/or possibly add a second
hostname to the certificate.
Comment 1 Ricky Zhou 2008-03-17 14:18:05 EDT
It looks like this has been fixed now.  

Note You need to log in before you can comment on or make changes to this bug.