Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1980074

Summary: Provisioning Azure fails in Kickstart default finish when using Ansible Callback
Product: Red Hat Satellite Reporter: Paul Armstrong <parmstro>
Component: Provisioning TemplatesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact: Ondrej Gajdusek <ogajduse>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.9.0CC: mhulan, tbrisker
Target Milestone: UnspecifiedKeywords: Patch, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-12-01 13:29:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Paul Armstrong 2021-07-07 17:20:56 UTC
Description of problem:
Provisioning Azure fails in Kickstart default finish when using Ansible Callback - the script /root/ansible_provisioning_call.sh is not executable

Version-Release number of selected component (if applicable):
6.9.3

How reproducible:
Always

Steps to Reproduce:
1. Configure Capsule and Tower for callback and Azure provisioning
2. Configure Host group for callback
3. Deploy new system to azure 

Actual results:
Kickstart default finish fails with permission denied on /root/ansible_provisioning_call.sh

Expected results:
Success

Additional info:
Modifying the section to the example below corrects the issue.

<% if host_param_true?('ansible_tower_provisioning') -%>
<%= save_to_file('/root/ansible_provisioning_call.sh', snippet('ansible_tower_callback_script')) %>
sudo chmod +x /root/ansible_provisioning_call.sh
sudo /root/ansible_provisioning_call.sh
<% end -%>

Comment 1 Tomer Brisker 2021-12-01 13:29:43 UTC

*** This bug has been marked as a duplicate of bug 1956124 ***