Bug 198026 - Ineffective file writing in latest nautilus
Ineffective file writing in latest nautilus
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 02:25 EDT by The Source
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 09:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2006-07-08 02:25:20 EDT
Description of problem:
When I use Copy/Paste command, the writing process is VERY ineffective. Just try
to write large file ti ntfs volume to see what I mean (you need ntfsprogs from
www.linux-ntfs.org)
 
Version-Release number of selected component (if applicable):
2.14.1-1.fc5.1

How reproducible:
Frequently when writing files larger 1M to ntfs volumes

Steps to Reproduce:
1.make sure you have lates ntfsprogs (www.linux-ntfs.org)
2.mount ntfs volume with it.
3.try to copy large file to this volume
  
Actual results:


Expected results:


Additional info:
ntfsprogs developers confirm that this is known nautilus bug. You are very well
advesed to fix it
Comment 1 The Source 2006-07-09 23:51:50 EDT
Note that this happens not in all folders. To some folders you can copy normally
and to other ones - buggy
Comment 2 Alexander Larsson 2006-08-22 09:14:48 EDT
Is it only slow on ntfs? Is it copies from other filesystems to ntfs, or ntfs to
ntfs.

Exactly what did the ntfs developers say. We use the same writing code on all
filesystems, it shouldn't be slower on some only.
Comment 3 The Source 2006-08-22 09:21:38 EDT
Here's part of dialog with ntfsprogs developers:
The Source
Guest

PostPosted: Fri Jul 07, 2006 4:58 pm    Post subject: Writing is slow 	Reply
with quote
I use ntfsprogs to mount and use my ntfs volumes. It allows me to write to ntfs
but on very low speed. What is the problem? Should I set some options to
ntfsmount to fix this?
Back to top 	
	 	
The Source
Guest
	
PostPosted: Fri Jul 07, 2006 5:17 pm    Post subject: console and nautilus 
Reply with quote
Hmm....
If I use cp command, then writing is fast, but if I use Copy/Paste by nautilus
then it is very slow
Back to top 	
	 	
The Source
Guest

PostPosted: Fri Jul 07, 2006 5:26 pm    Post subject: nautilus bug 	Reply with quote
Looks like it is nautilus incompatibility
Writing in any other way is fast
Back to top 	
	 	
szaka
Linux NTFS developer

Joined: 08 Sep 2005
Posts: 158
Location: Nagykanizsa, Hungary
	
PostPosted: Fri Jul 07, 2006 5:39 pm    Post subject: Writing is slow 	Reply
with quote
On Fri, 7 Jul 2006, Anonymous wrote:

Quote:
Looks like it is nautilus incompatibility

Yes, it's known nautilus is very inefficent. Try to upgrade your distro
(which is actually what?), perhaps they fixed it already. If not then
please report to them. Thanks.
Comment 4 Alexander Larsson 2006-08-22 09:28:52 EDT
Not very detailed. We use standard read write calls to copy files. I'm not sure
how that could work fine on all filesystems except ntfs (especially how it can
work on some folders and not others!).

Anyway, we (==redhat) don't support ntfs, neither do i have any ntfs filesystems
to test on, so I can't really do much about this right now.

Note You need to log in before you can comment on or make changes to this bug.