Bug 198066 - Open Office Base crashed
Open Office Base crashed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 20:28 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 02:59:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages openoffice seems are helpful (5.73 KB, text/plain)
2006-07-08 20:28 EDT, Jim Cornette
no flags Details
added link from master form to subform (3.16 KB, text/plain)
2006-07-08 21:40 EDT, Jim Cornette
no flags Details
what is being created (6.96 KB, application/vnd.oasis.opendocument.text)
2006-07-08 23:11 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-07-08 20:28:24 EDT
Description of problem:
While working with openoffice-base a crash was experienced. I created a table,
summation query and form based on the table as form and the summation query as a
subform.
The error occurred when I tried to enter new data into the table via the form.

Version-Release number of selected component (if applicable):
openoffice.org-base-2.0.3-7.4

How reproducible:
Create database with one table, one query to add up sums and a form with the
table as the main form and the sum query as the subform.


Steps to Reproduce:
1.create database
2.add new record to table via the created form
3.see OOo crash, include with bug report
  
Actual results:

Crashed and brought up window with error related information to add to report

Expected results:
Being able to add a new record to the database via created form.

Additional info:

I have created a lot of databases using Access since 1997 and note that
openoffice-base is fairly primitive. I am glad though that there is an
alternative database where a user can create personal databases for usage in a
simple manner.
Major features lacking are no ability or obvious way to format query results to
display in currency, percentage and other aspects.

Attached is the dumped file pasted into gedit.
Comment 1 Jim Cornette 2006-07-08 20:28:24 EDT
Created attachment 132117 [details]
messages openoffice seems are helpful
Comment 2 Jim Cornette 2006-07-08 21:38:53 EDT
After recovering from the crash, the query was gone, the form was gone. Also,
the cell formatting for currency, percentage and date were all missing.
I experienced another crash under different circumstances. I added conditions
for the subform to link to the main form. SQL werrors experienced with this problem.
Comment 3 Jim Cornette 2006-07-08 21:40:40 EDT
Created attachment 132119 [details]
added link from master form to subform

errors when loading form. Second crash of forms
Comment 4 Jim Cornette 2006-07-08 23:11:35 EDT
Created attachment 132121 [details]
what is being created

This is an odt file to show the form and subform created
Comment 5 Caolan McNamara 2006-07-10 08:48:48 EDT
Can you give me a step by step process to get your crash ?
Comment 6 Jim Cornette 2006-07-10 21:09:21 EDT
Table:
create table with several field in them. ID and institute as text. 
Create fields as type real number. 
Create filters for real number fields as currency and one as percentage.

Query:
create query for balance and monthly payments as SUM function.

Form:
Use wizard to create form based on table (select all fields for form) and add a
subform by selecting the query. (select all fields for form.)

Choose columnar labels-left for the main form and columnar labels-left for the
subform. 
Open form and go to last record, try to enter data in the form. The form crashed
with the first exception.
On the second crash, I chose to link the main form balance to the subform
balance summary. I ended up having an additional error followed by the second
exception output.

When I created the first form as a datasheet and the summary query as columnar
labels-left, the form works other than not maintaining the currency and
percentage formatting that I desired. If I recall, the columnar labels left form
maintained proper cell formatting. Entering data was the drawback.
Comment 7 Caolan McNamara 2006-07-11 07:16:31 EDT
Can you give this a go for me, setup in oobase the situation before it would
crash, and then do a"SHUTDOWN COMPACT" in the Tools/SQL window and attach the
saved .odb here.
Comment 8 Jim Cornette 2006-07-11 20:38:49 EDT
I tried to recreate the crash with the present development versions and
everything is working now. I did try the SHUTDOWN COMPACT as described and had a
successful prompt returned.
The bug seems to not be present any longer with forms of different views nor
losing formatting for currency, date or percentage.

The only actions that I took to differentiate the system was to remove stray
#prelink# files and allow prelink to complete its run on the system.

I like that the crash is gone. I just feel like time was consumed on a bug which
seemed to stop happening mysteriously.

The database is working with both data form and columnar now. Should I close
this bug?
Comment 9 Caolan McNamara 2006-07-12 04:01:23 EDT
That is very strange, there may have been something that changed in gcj/gcc or
perhaps there was something to the prelink stuff.

Yeah, feel free to close it if you cannot reproduce anymore, and feel equally
free to reopen if it returns
Comment 10 Caolan McNamara 2006-07-13 02:59:18 EDT
We'll close it for now, and reopen if it returns
Comment 11 Jim Cornette 2006-07-13 22:00:22 EDT
If it resurfaces, I will re-open the report. I'm glad that it started working,
prelink or improvements to the libraries. I'll take either. 

Note You need to log in before you can comment on or make changes to this bug.