RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1980797 - Rebase SBD on upstream 1.5.0 for RHEL 8.5
Summary: Rebase SBD on upstream 1.5.0 for RHEL 8.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sbd
Version: 8.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Klaus Wenninger
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-09 14:43 UTC by Klaus Wenninger
Modified: 2021-11-10 01:39 UTC (History)
4 users (show)

Fixed In Version: sbd-1.5.0-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-09 18:50:38 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker CLUSTERQE-4864 0 None None None 2021-08-25 14:20:07 UTC
Red Hat Product Errata RHBA-2021:4310 0 None None None 2021-11-09 18:50:39 UTC

Description Klaus Wenninger 2021-07-09 14:43:59 UTC
In RHEL-8.5 we've already enabled startup/shutdown-syncing with pacemaker as default including the dependencies between pacemaker & sbd packages needed.

With sbd upstream-release 1.5.0 this default syncing was enabled as well.
That was adopted in Fedora-Rawhide sbd-1.5.0.
So for consistency it makes sense to sync the codebase with RHEL-8.5 as well.

Apart from the startup/shutdown-syncing default upstream sbd-1.5.0 brings mainly smaller bugfixes so that the risk and retest-effort should be minimal.

Comment 1 Klaus Wenninger 2021-07-09 15:19:49 UTC
Following is a list of fixes brought in with syncing with the Fedora Package

patches on top of 1.5.0: 

Fix: sbd-inquisitor: tolerate and strip any leading spaces of command line option values
Log: sbd-inquisitor: tell the actual watchdog device specified with `-w`
Build: Fix: correctly derrive package version from git
  fixes a regression brought in previously

Changes since 1.4.2:
    
- default to resource-syncing with pacemaker in spec-file and configure.ac
  This default has to match between sbd and pacemaker and
  thus qualifies this release for a minor-version-bump
- fix some regressions introduced by adding configurability previously
- adapt description of startup/shutdown sync with pacemaker
- make watchdog warning messages more understandable

Build: Fix: package version if release not labelled yet
Fix: sbd-inquisitor: prevent segfault if no command is supplied
Fix: sbd-inquisitor: take the defaults for the options set in sysconfig with empty strings
Log: sbd-inquisitor,sbd-md: make watchdog warning messages more understandable
Fix: sbd-inquisitor: calculate the default timeout for watchdog warning based on the watchdog timeout consistently
Fix: sbd-inquisitor: ensure the timeout for watchdog warning specified with `-5` option is respected
Fix: sbd-common: ensure the default timeout for watchdog warning is about 3/5 of the default watchdog timeout
Doc: adapt description of startup/shutdown sync with pacemaker
Fix: sbd-inquisitor: check SBD_SYNC_RESOURCE_STARTUP only in watch mode

Comment 7 Michal Mazourek 2021-08-30 11:32:29 UTC
Regression test suite was conducted, any potential issues will be reviewed and filed as new bzs.
Marking as VERIFIED for sbd-1.5.0-2.el8

Comment 9 errata-xmlrpc 2021-11-09 18:50:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sbd bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4310


Note You need to log in before you can comment on or make changes to this bug.