Bug 198081 - spamd is SO slow
spamd is SO slow
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 05:43 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 12:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-07-09 05:43:59 EDT
downloading e-mail with evolution is REALLY slow.
It takes about two minutes over a fast line to download 150 e-mails.

top shows spamd hogging the cpu.
Comment 1 Warren Togami 2006-07-09 21:15:20 EDT
This is not enough information to possibly diagnose the problem.

Are you having long DNS timeouts by chance?
Comment 2 Need Real Name 2006-07-10 02:23:29 EDT
I doubt it, but I'll check.

In the meantime:
Time to download 100 test e-mails without spamd: about 1 second.
With spamd: about 10 seconds.

Each mail seems to be passed to spamd before the next one is downloaded, which
is a bit bizarre.
Comment 3 Jeroen van Meeuwen 2006-07-10 07:18:07 EDT
Wouldn't you consider this undesirable behaviour by evolution, instead of
unsuspected behaviour by spamassassin?
Comment 4 Need Real Name 2006-07-10 07:59:13 EDT
Good point, yes, but it was more of a side comment.

spamd is still hogging the cpu, the db is only ten megs.
Comment 5 Need Real Name 2006-07-11 12:04:19 EDT
It's not a dns problem. I added the mail server to /etc/hosts before checking
e-mail, and it's not any faster.
Comment 6 Steven Pritchard 2006-07-11 12:36:58 EDT
(In reply to comment #5)
> It's not a dns problem. I added the mail server to /etc/hosts before checking
> e-mail, and it's not any faster.

Which won't help a bit with spamassassin's DNSBL checks...
Comment 7 Need Real Name 2006-07-11 12:43:51 EDT
Okay, so six comments in we're at where comment number 2 should have been.

"Have you tried turning off DNS checks by adding -L to SPAMDOPTIONS in
/etc/sysconfig/spamassassin ?"

And the answer is no, I haven't, but I'll try it.
Comment 8 Need Real Name 2006-07-13 09:14:40 EDT
Hurrah! Disabling non-local checks, did make spamd eat less CPU - MUCH less CPU.
Which makes me wonder what on earth it was doing..

I have filed a separate bug 198767 about evolution seeming to pass each
individual mail to spamd before downloading the next.
Comment 9 Warren Togami 2006-07-13 12:24:13 EDT
There is something wrong with your network, it is not slow on a properly
configured network.

Note You need to log in before you can comment on or make changes to this bug.