Bug 198092 - uw-imap: ipop3d: g_initialize.c:97: gss_release_oid
uw-imap: ipop3d: g_initialize.c:97: gss_release_oid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-09 09:04 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 13:45:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-07-09 09:04:51 EDT
Description of problem:
Since installing krb5-libs-1.5-1, I get the following problem when trying 
"telnet localhost 110": 

ipop3d: g_initialize.c:97: gss_release_oid: Assertion `(&(&_m->os)->n)-
>initialized == K5_MUTEX_DEBUG_INITIALIZED' failed.

Version-Release number of selected component (if applicable):
uw-imap-2004g-4.fc5.2
krb5-libs-1.5-1

How reproducible:
Everytime, see above.

Actual results:
Completely unusable ipop3d.

Expected results:
Working ipop3d like in the past ;-)

Additional info:
I guess the problem is within uw-imap, as everything else krb5 related works 
fine and a rebuild of uw-imap didn't also resolve my problem. Please re-assign 
to krb5, if necessary.
Comment 1 Robert Scheck 2006-07-23 07:12:59 EDT
Got some input that my problem is more krb5 related rather to uw-imap
Comment 2 Rex Dieter 2006-08-07 07:47:11 EDT
ping... Nalin, comment(s)?

p.s. This also affects pine, and likely any app linking against libc-client.
Comment 3 Robert Scheck 2006-08-07 07:52:25 EDT
As already said, I'm not absolutely sure whether this problem is krb5 or uw-
imap related. Sent message to krb5-bugs mailing list, but no response, yet:

  http://mailman.mit.edu/pipermail/krb5-bugs/2006-August/004843.html

Dunno, maybe somebody at Red Hat has the knowledge and is able to figger out 
what goes wrong here...
Comment 4 Robert Scheck 2006-08-07 13:37:55 EDT
Okay, the problem IS caused by krb5 and there's also a fix available now:

 http://mailman.mit.edu/pipermail/krb5-bugs/2006-August/004835.html
 http://mailman.mit.edu/pipermail/krb5-bugs/2006-August/004848.html
 http://mailman.mit.edu/pipermail/krb5-bugs/2006-August/004849.html

Include the fix and everything works as expected like in the past. As also
other applications will be affected by this regression too, I'm marking as 
FC6Blocker for now.

Note You need to log in before you can comment on or make changes to this bug.