Bug 198124 - binaries should not be under /usr/lib/mailman/bin
binaries should not be under /usr/lib/mailman/bin
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 19:35 EDT by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 06:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2006-07-09 19:35:00 EDT
From the FHS: "/usr/lib includes object files, libraries, and internal 
binaries that are not intended to be executed directly by users or shell 
scripts".

Some of the programs in /usr/lib/mailman/bin are supposed to be directly 
executed by the sys-admin, one example is mmsitepass.  The mmsitepass program 
belongs in /usr/sbin (or at least a sym-link so that the sys-admin can run it 
without doing an "rpm -ql mailman|grep mmsitepass" to find it first).
Comment 1 Tomas Smetana 2007-05-02 06:00:08 EDT
From the online documentation of Mailman
(http://www.gnu.org/software/mailman/site.html): "You must run these scripts
from the bin directory in the Mailman installation location...".

I agree Mailman is not FHS compliant much. But finding what script under what
circumstances can be run from outside the Mailman installation directory is not
worth the effort -- the only thing we can get are distro-specific issues. Also
note that all the binaries have (and must have) sgid on.

Note You need to log in before you can comment on or make changes to this bug.