Bug 1981303 - libguestfs: FTBFS in Fedora rawhide
Summary: libguestfs: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libguestfs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F35FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-07-12 10:45 UTC by Tomáš Hrnčiar
Modified: 2021-07-16 10:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-16 10:37:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-07-12 10:45:10 UTC
Description of problem:
Package libguestfs fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.45.6-6.fc35

Steps to Reproduce:
koji build --scratch f35 libguestfs-1.45.6-6.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/libguestfs

Comment 1 Richard W.M. Jones 2021-07-16 10:00:52 UTC
When we load the virtio-scsi module it doesn't seem to be able to
find any disks:

supermin: internal insmod virtio_scsi.ko
[    8.188269] scsi host2: Virtio SCSI HBA
[    8.238262] scsi 2:0:0:0: Power-on or device reset occurred
[    8.239262] scsi 2:0:0:0: Power-on or device reset occurred
[    8.286254] scsi 2:0:1:0: Power-on or device reset occurred
[    8.287254] scsi 2:0:1:0: Power-on or device reset occurred

Normal output looks more like this:

supermin: internal insmod virtio_scsi.ko
[    0.762503] scsi host2: Virtio SCSI HBA
[    0.764214] scsi 2:0:0:0: Direct-Access     QEMU     QEMU HARDDISK    2.5+ PQ: 0 ANSI: 5
[    0.766045] scsi 2:0:1:0: Direct-Access     QEMU     QEMU HARDDISK    2.5+ PQ: 0 ANSI: 5
[    0.781277] sd 2:0:0:0: Power-on or device reset occurred
[    0.782211] sd 2:0:0:0: Attached scsi generic sg0 type 0
[    0.783246] sd 2:0:1:0: Attached scsi generic sg1 type 0
[    0.784101] sd 2:0:1:0: Power-on or device reset occurred
[    0.784999] sd 2:0:0:0: [sda] 204800 512-byte logical blocks: (105 MB/100 MiB)
[    0.786127] sd 2:0:0:0: [sda] Write Protect is off
...

Comment 2 Richard W.M. Jones 2021-07-16 10:02:26 UTC
Created attachment 1802357 [details]
build.log

Attach build.log for future reference.

Comment 3 Richard W.M. Jones 2021-07-16 10:37:17 UTC
NOT able to reproduce this locally with:

kernel-5.13.0-0.rc4.20210603git324c92e5e0ee.35.fc35.x86_64
kernel-5.14.0-0.rc1.20210714git40226a3d96ef.18.fc35.x86_64
libvirt-libs-7.4.0-2.fc35.x86_64
libvirt-libs-7.5.0-1.fc35.x86_64
seabios-bin-1.14.0-3.fc35.noarch
seabios-bin-1.14.0-4.fc35.noarch
qemu-system-x86-6.0.0-1.fc35.x86_64
qemu-system-x86-6.0.0-9.fc35.x86_64
glibc-2.33.9000-37.fc35.x86_64
glibc-2.33.9000-43.fc35.x86_64

I can't think of any other component that could cause this, so
I tried a scratch build with latest Rawhide:

https://koji.fedoraproject.org/koji/taskinfo?taskID=71997943

As this was successful, I guess this was just a temporary "blip"
or problem with the kernel which has since been resolved.


Note You need to log in before you can comment on or make changes to this bug.