Bug 1981342 - F35FailsToInstall: 0ad
Summary: F35FailsToInstall: 0ad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: 0ad
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1989006 (view as bug list)
Depends On:
Blocks: F35FailsToInstall F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-07-12 12:44 UTC by Miro Hrončok
Modified: 2021-10-03 00:14 UTC (History)
7 users (show)

Fixed In Version: 0ad-0.0.25b-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-03 00:14:47 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-07-12 12:44:18 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (0ad) Fails To Install in Fedora 35:

can't install 0ad:
  - nothing provides libfmt.so.7()(64bit) needed by 0ad-0.0.24b-3.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-07-20 07:40:58 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2021-08-02 10:09:08 UTC
*** Bug 1989006 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2021-08-10 11:00:13 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Ben Cotton 2021-08-10 13:12:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 5 Miro Hrončok 2021-09-11 05:43:15 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/0ad by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 6 Bill 2021-09-27 12:29:40 UTC
I get this problem on F35:

dnf install 0ad
Last metadata expiration check: 0:18:05 ago on Tue 28 Sep 2021 01:01:58.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_filesystem.so.1.75.0()(64bit) needed by 0ad-0.0.24b-3.fc35.x86_64
  - nothing provides libfmt.so.7()(64bit) needed by 0ad-0.0.24b-3.fc35.x86_64
  - nothing provides 0ad-data = 0.0.24b needed by 0ad-0.0.24b-3.fc35.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 7 Fedora Update System 2021-09-27 12:52:47 UTC
FEDORA-2021-a804357097 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a804357097

Comment 8 Miro Hrončok 2021-09-28 20:12:56 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 9 Fedora Update System 2021-09-29 02:10:59 UTC
FEDORA-2021-a804357097 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a804357097`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a804357097

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Blocker Bugs Application 2021-10-02 05:51:34 UTC
Proposed as a Freeze Exception for 35-final by Fedora user bruno using the blocker tracking app because:

 This resolves a FTI bug that could affect people upgrading to f35. It is going to be close as to whether this bug can move to stable by time, before the freeze deadline. (Bodhi seems to indicate another 4 days are needed.) I'm actually hoping for some karma, so this makes it in with time to spare.

Comment 11 Bruno Wolff III 2021-10-02 05:55:49 UTC
We don't need input from Paulo at this point for this bug, so I'm clearing the needinfo flag for him.

Comment 12 Bruno Wolff III 2021-10-02 06:05:17 UTC
I have played the rawhide (f36) version of this game multiplayer on a local lan for a couple of hours. I have played another couple of hours single player. So the game is at least usable on rawhide, which is a big step up from failing to install. The f35 build used the same spec file and f35 and f36 haven't diverged too much so I expect the build to be at least usable there.
I have not tested playing multiplayer with other builds (e.g. from the 0AD website at play0ad.com) to see if there are compatibility issues with them. There is a small chance that the f35 version might have ones that the f33 and f34 builds don't have because of the change to get the build to happen using python 3.10. Even so, I think having an installable, playable game (solo or with other f35 users) is a big step up from not being installable on f35.

Comment 13 Bill 2021-10-02 10:58:22 UTC
It's working for me now. Successfully installed 0ad in f35.

Comment 14 Fedora Update System 2021-10-03 00:14:47 UTC
FEDORA-2021-a804357097 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.