Bug 1981407 (CVE-2021-3642) - CVE-2021-3642 wildfly-elytron: possible timing attack in ScramServer
Summary: CVE-2021-3642 wildfly-elytron: possible timing attack in ScramServer
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-3642
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1978312 1981408
TreeView+ depends on / blocked
 
Reported: 2021-07-12 13:58 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-20 14:08 UTC (History)
71 users (show)

Fixed In Version: Wildfly Elytron 1.10.14.Final, Wildfly Elytron 1.15.5.Final, Wildfly Elytron 1.16.1.Final
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Wildfly Elytron where ScramServer may be susceptible to Timing Attack if enabled. The highest threat of this vulnerability is confidentiality.
Clone Of:
Environment:
Last Closed: 2021-10-20 14:08:24 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:3656 0 None None None 2021-09-23 16:16:08 UTC
Red Hat Product Errata RHSA-2021:3658 0 None None None 2021-09-23 16:24:44 UTC
Red Hat Product Errata RHSA-2021:3660 0 None None None 2021-09-23 16:30:33 UTC
Red Hat Product Errata RHSA-2021:3880 0 None None None 2021-10-20 11:30:17 UTC

Description Guilherme de Almeida Suckevicz 2021-07-12 13:58:30 UTC
A flaw was found in Wildfly Elytron where ScramServer may be susceptible to Timing Attack if enabled. The highest threat of this vulnerability is confidentiality.

Reference:
https://issues.redhat.com/browse/ELY-2147

Comment 12 errata-xmlrpc 2021-09-23 16:16:05 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7

Via RHSA-2021:3656 https://access.redhat.com/errata/RHSA-2021:3656

Comment 13 errata-xmlrpc 2021-09-23 16:24:41 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8

Via RHSA-2021:3658 https://access.redhat.com/errata/RHSA-2021:3658

Comment 14 errata-xmlrpc 2021-09-23 16:30:29 UTC
This issue has been addressed in the following products:

  EAP 7.4.1 release

Via RHSA-2021:3660 https://access.redhat.com/errata/RHSA-2021:3660

Comment 15 errata-xmlrpc 2021-10-20 11:30:13 UTC
This issue has been addressed in the following products:

  Red Hat build of Quarkus 2.2.3

Via RHSA-2021:3880 https://access.redhat.com/errata/RHSA-2021:3880

Comment 16 Product Security DevOps Team 2021-10-20 14:08:24 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-3642


Note You need to log in before you can comment on or make changes to this bug.