Bug 1981558 - ValueError: Unknown character in version: 1.0.6.*
Summary: ValueError: Unknown character in version: 1.0.6.*
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyproject-rpm-macros
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-12 19:43 UTC by Major Hayden 🤠
Modified: 2021-08-02 01:06 UTC (History)
4 users (show)

Fixed In Version: pyproject-rpm-macros-0-44.fc35 pyproject-rpm-macros-0-46.fc34 pyproject-rpm-macros-0-46.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-02 01:03:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Major Hayden 🤠 2021-07-12 19:43:01 UTC
I was building python-azure-cli-core 2.26.0 with pyproject-rpm-macros and had this error:

Handling azure-cli-telemetry (==1.0.6.*) from wheel metadata: Requires-Dist
Requirement not satisfied: azure-cli-telemetry (==1.0.6.*)
Traceback (most recent call last):
  File "/usr/lib/rpm/redhat/pyproject_buildrequires.py", line 407, in main
    generate_requires(
  File "/usr/lib/rpm/redhat/pyproject_buildrequires.py", line 346, in generate_requires
    generate_run_requirements(backend, requirements)
  File "/usr/lib/rpm/redhat/pyproject_buildrequires.py", line 229, in generate_run_requirements
    requirements.extend(requires, source=f'wheel metadata: {key}')
  File "/usr/lib/rpm/redhat/pyproject_buildrequires.py", line 147, in extend
    self.add(req_str, source=source)
  File "/usr/lib/rpm/redhat/pyproject_buildrequires.py", line 124, in add
    raise ValueError(
ValueError: Unknown character in version: 1.0.6.*. (This is probably a bug in pyproject-rpm-macros.)
error: Bad exit status from /var/tmp/rpm-tmp.s2olTn (%generate_buildrequires)
    Bad exit status from /var/tmp/rpm-tmp.s2olTn (%generate_buildrequires)

Requirements from upstream: https://github.com/Azure/azure-cli/blob/24121071c2b23624d420ea23417c08f51f574b99/src/azure-cli-core/setup.py#L48

Comment 1 Miro Hrončok 2021-07-12 20:30:27 UTC
Thanks for the report. I think I know where the problem is.

Comment 3 Fedora Update System 2021-07-19 07:59:01 UTC
FEDORA-2021-fe1bbcfd07 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-fe1bbcfd07

Comment 4 Fedora Update System 2021-07-19 08:01:26 UTC
FEDORA-2021-ffa81019cf has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ffa81019cf

Comment 5 Fedora Update System 2021-07-19 08:01:38 UTC
FEDORA-2021-fe1bbcfd07 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2021-07-20 01:01:20 UTC
FEDORA-2021-ffa81019cf has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ffa81019cf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ffa81019cf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-07-20 01:47:16 UTC
FEDORA-2021-9874c0ec7b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-9874c0ec7b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-9874c0ec7b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-07-24 01:18:22 UTC
FEDORA-2021-fcf5e2adc6 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-fcf5e2adc6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-fcf5e2adc6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-07-24 01:25:00 UTC
FEDORA-2021-3d06d86fe9 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3d06d86fe9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3d06d86fe9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-08-02 01:03:20 UTC
FEDORA-2021-fcf5e2adc6 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-08-02 01:06:14 UTC
FEDORA-2021-3d06d86fe9 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.