Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
+++ This bug was initially created as a clone of Bug #1973273 +++
Description of problem:
man page for ipa-server-upgrade states that it is not meant to be run by end user but when upgrade fails, /var/log/ipaupgrade.log states that run ipa-server-upgrade command manually. Its contradictory statement.
Version-Release number of selected component (if applicable):
ipa-server-4.9.3-1.module+el8.5.0+10565+ae980a94.x86_64
How reproducible:
Steps to Reproduce:
1. man ipa-server-upgrade
Actual results:
$ man ipa-server-upgrade
ipa-server-upgrade(1) IPA Manual Pages ipa-server-upgrade(1)
NAME
ipa-server-upgrade - upgrade IPA server
SYNOPSIS
ipa-server-upgrade [options]
DESCRIPTION
ipa-server-upgrade is used to upgrade IPA server when the IPA packages are being updated. It is not intended to be
executed by end-users.
ipa-server-upgrade will:
* update LDAP schema
* process all files with the extension .update in /usr/share/ipa/updates (including update plugins).
* upgrade local configurations of IPA services
Expected results:
Specify that ipa-server-upgrade can be run by user as/when needed.
Additional info:
--- Additional comment from Florence Blanc-Renaud on 2021-07-07 12:06:39 UTC ---
Upstream ticket:
https://pagure.io/freeipa/issue/8913
--- Additional comment from Florence Blanc-Renaud on 2021-07-07 19:56:04 UTC ---
Fixed upstream
master:
https://pagure.io/freeipa/c/a7c8517826b789941f5c769c626393cacdc5bb1e
--- Additional comment from Florence Blanc-Renaud on 2021-07-08 16:11:32 UTC ---
Fixed upstream
ipa-4-9:
https://pagure.io/freeipa/c/195035cef51a132b2b80df57ed50f2fe620244e6
Comment 1Florence Blanc-Renaud
2021-07-13 12:10:44 UTC
Following is the description text now in man page of ipa-server-upgrade, marking it pre-verified.
-----------------------------------------------
DESCRIPTION
ipa-server-upgrade is executed automatically to upgrade IPA server when the IPA packages are being updated. It is not intended to be executed by end-users, unless the automatic
execution reports an error. In this case, the administrator needs to identify and fix the issue that is causing the upgrade failure (with the help of /var/log/ipaupgrade.log) and
manually re-run ipa-server-upgrade.
[root@10 ~]# rpm -q ipa-server
ipa-server-4.9.6-4.el9.x86_64
[root@10 ~]#
Following is the description text now in man page of ipa-server-upgrade in nightly (RHEL-9.0.0-20210728.4), marking it verified.
DESCRIPTION
ipa-server-upgrade is executed automatically to upgrade IPA server when the IPA packages are being updated. It is not intended to be executed by end-users, unless the automatic
execution reports an error. In this case, the administrator needs to identify and fix the issue that is causing the upgrade failure (with the help of /var/log/ipaupgrade.log) and
manually re-run ipa-server-upgrade.
[root@10 ~]# rpm -q ipa-server
ipa-server-4.9.6-4.el9.x86_64
[root@10 ~]#