Bug 19818 - makedepend command line parsing broken
Summary: makedepend command line parsing broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-25 17:39 UTC by Georg Nikodym
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 11:37:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Georg Nikodym 2000-10-25 17:39:37 UTC
The following (from one of our Makefiles) no longer works:

	makedepend -fMakefile.deps -- $(CFLAGS) -- \
		foo.c

Instead I get:

(keller) 1032$ make depend
Makefile:76: Makefile.deps: No such file or directory
/bin/rm -f Makefile.deps
touch Makefile.deps
makedepend -fMakefile.deps -- -D__KERNEL__ -DMODULE -O -Wall
-I../someplace  -- \
	foo.c
Unknown option '-Wall' ignored
rm: unrecognized option `--.bak'
Try `rm --help' for more information.
cp: missing destination file
Try `cp --help' for more information.
Appending dependencies to --
?
/bin/rm -f Makefile.deps.bak
make: Nothing to be done for `depend'.
(keller) 1033$ 

I find that makedepend is now a script...  Hmm educated whim, if I add a
space between
the -f and the Makefile.dep things work.

Comment 1 Need Real Name 2000-12-11 17:15:44 UTC
I ran into this too.  Adding a space makes things work, but doesn't match the
man page.  The extra space works in the XFree86-3.3/RH6.2 version, too.

The -p option does not seem to be supported anymore.  This breaks my
multi-architecture build system (maybe I should switch to autoconf :).  This
worked in XFree86-3.3/RH6.2.

-Dan Christian


Comment 2 Mike A. Harris 2001-03-08 11:37:48 UTC
Asking upstream...

Comment 3 Mike A. Harris 2001-04-02 19:20:51 UTC
Fixed in 4.0.3 in rawhide (actually it was fixed just after 4.0.2b was
tagged on March 13th).

I dunno about the -p one.  File a new bug report if it isn't fixed in
4.0.3 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.