Bug 198186 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 09:16 EDT by Karsten Hopp
Modified: 2013-07-02 19:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 09:59:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 09:16:28 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


db4-tcl-4.3.29-4
undefined symbol: Tcl_SetObjLength      (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_ListObjGetElements        (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_AddErrorInfo      (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_NewByteArrayObj   (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_PkgProvide        (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_GetStringFromObj  (/usr/lib/libdb_tcl-4.3.so)
undefined symbol: Tcl_GetByteArrayFromObj       (/usr/lib/libdb_tcl-4.3.so)
...
...
Comment 1 Jindrich Novy 2006-07-10 09:48:34 EDT
Hi Karsten,

works for me on i386:

# rpm -ql db4 | grep lib.*so | xargs ldd -r
/lib/libdb-4.3.so:
        linux-gate.so.1 =>  (0xb7fe3000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00db1000)
        libc.so.6 => /lib/libc.so.6 (0x00df6000)
        /lib/ld-linux.so.2 (0x0017e000)
/usr/lib/libdb-4.3.so:
        linux-gate.so.1 =>  (0xb7f71000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0087f000)
        libc.so.6 => /lib/libc.so.6 (0x00328000)
        /lib/ld-linux.so.2 (0x00bfe000)
/usr/lib/libdb_cxx-4.3.so:
        linux-gate.so.1 =>  (0xb7f14000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00f77000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00d19000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00be7000)
        libm.so.6 => /lib/libm.so.6 (0x0083f000)
        libc.so.6 => /lib/libc.so.6 (0x005ed000)
        /lib/ld-linux.so.2 (0x002db000)
# rpm -q db4
db4-4.3.29-4

If you have further details please feel free to reopen this bug.
Comment 2 Jindrich Novy 2006-07-10 09:59:25 EDT
Ah, noticed you checked db4_tcl.

But worksforme anyway ;-)

# tclsh
% load /usr/lib/libdb_tcl-4.3.so
%

So that all symbols are corretly resolved.
Comment 3 Karsten Hopp 2006-07-11 10:07:56 EDT
thanks for the clarification !

Note You need to log in before you can comment on or make changes to this bug.