Bug 198188 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 09:18 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 08:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 09:18:31 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


freeradius-1.1.2-1
undefined symbol: debug_flag    (/usr/lib/libeap-1.1.2.so)
undefined symbol: SSL_set_ex_data       (/usr/lib/libeap-1.1.2.so)
undefined symbol: RSA_generate_key      (/usr/lib/libeap-1.1.2.so)
undefined symbol: SSL_state     (/usr/lib/libeap-1.1.2.so)
undefined symbol: SSL_get_error (/usr/lib/libeap-1.1.2.so)
undefined symbol: HMAC_Final    (/usr/lib/libeap-1.1.2.so)
undefined symbol: SSL_read      (/usr/lib/libeap-1.1.2.so)
undefined symbol: HMAC_Init_ex  (/usr/lib/libeap-1.1.2.so)
undefined symbol: EVP_md5       (/usr/lib/libeap-1.1.2.so)
...
...
Comment 1 Karsten Hopp 2007-04-05 06:06:40 EDT
there are still many unresolved symbols in freeradius-1.1.5-1
Comment 2 Thomas Woerner 2007-08-28 08:59:50 EDT
These are modules - works as intended.

Note You need to log in before you can comment on or make changes to this bug.