Bug 198191 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-sharp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 09:23 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-sharp-0.12.0-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 13:09:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 09:23:56 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


evolution-sharp-0.11.1-5
undefined symbol: GNOME_Evolution_Shell_findComponent   (/usr/lib/libevolutionglue.so)
Comment 1 Matthew Barnes 2006-08-07 10:08:53 EDT
It looks like this is indeed an issue, since recent versions of Evolution no
longer implement this function.  Evolution-Shell's ChangeLog says the
"findComponent" function was commented out to prevent a circular dependency.

Will investigate this further and file an upstream bug report if necessary.
Comment 2 Matthew Barnes 2006-09-01 12:48:50 EDT
Just for my own reference:

GNOME_Evolution_Shell_findComponent()
Which is in emrg_initialize_session_and_listeners()  [static]
Which is called from e_mail_remote_glue_lookup_plugin_and_initialize()
Which is referenced in evolution/evolution-api-1.x.raw  (for x in {2, 4, 6})
Which is used to generate evolution-api.xml.
Which is used by the GAPI tools Gtk# [1].

[1] http://www.mono-project.com/GAPI
Comment 3 Matthew Barnes 2006-12-07 13:09:44 EST
This seems to be fixed now in evolution-sharp-0.12.0-1.fc7.

Note You need to log in before you can comment on or make changes to this bug.