Bug 198192 - ldd -r reports undefined symbols
Summary: ldd -r reports undefined symbols
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ldd-r-kh
TreeView+ depends on / blocked
 
Reported: 2006-07-10 13:24 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 16:14:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 342830 None None None Never

Description Karsten Hopp 2006-07-10 13:24:38 UTC
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


evolution-data-server-devel-1.7.3-3
undefined symbol: e_passwords_get_password      (/usr/lib/libexchange-storage-1.2.so)
undefined symbol: e_passwords_forget_password   (/usr/lib/libexchange-storage-1.2.so)
undefined symbol: e_passwords_ask_password      (/usr/lib/libexchange-storage-1.2.so)
undefined symbol: e_passwords_add_password      (/usr/lib/libexchange-storage-1.2.so)
undefined symbol: e_passwords_remember_password (/usr/lib/libexchange-storage-1.2.so)

Comment 1 Matthew Barnes 2006-09-18 19:37:06 UTC
Looks like a typo in evolution-data-server/servers/exchange/storage/Makefile.am.

Comment 2 Matthew Barnes 2006-09-18 20:39:07 UTC
Actually it's much nastier than a simple typo.

The undefined symbols are provided by libedataserverui, but libexchange-storage
cannot link with that library or else it introduces a cyclic library dependency
and the build fails.

Comment 3 Matthew Barnes 2007-01-02 16:14:17 UTC
Closing as UPSTREAM since there is an equivalent upstream bug report.  I will
continue to track the problem there.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=342830


Note You need to log in before you can comment on or make changes to this bug.