Bug 198214 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgtk-java (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 10:31 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 17:27:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 10:31:35 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


libgtk-java-2.8.5-0
undefined symbol: _ZN3org11freedesktop5cairo7Context8finalizeEv (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context4saveEv     (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context7restoreEv  (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context11setOperatorEPNS1_8OperatorE       (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context9setSourceEPNS1_7PatternE   (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context12setSourceRGBEddd  (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context13setSourceRGBAEdddd        (/usr/lib/libgtkjava-2.8.so)
undefined symbol: _ZN3org11freedesktop5cairo7Context9setSourceEPNS1_7SurfaceEdd (/usr/lib/libgtkjava-2.8.so)
...
...
Comment 1 Stepan Kasal 2007-02-14 17:27:03 EST
Indeed, these symbols are provided by /usr/lib/libcairojava-1.0.so, from
cairo-java rpm.
So this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.