Bug 1982215 - tesseract: nothing provides liblept.so.5()(64bit) needed by tesseract-4.1.0-1.el8.x86_64
Summary: tesseract: nothing provides liblept.so.5()(64bit) needed by tesseract-4.1.0-1...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tesseract
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-14 12:53 UTC by cparg
Modified: 2021-07-30 00:33 UTC (History)
2 users (show)

Fixed In Version: tesseract-4.1.0-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-30 00:33:12 UTC
Type: Bug


Attachments (Terms of Use)

Description cparg 2021-07-14 12:53:29 UTC
Description of problem:
When I try to install tesseract I get :
nothing provides liblept.so.5()(64bit) needed by tesseract-4.1.0-1.el8.x86_64

Version-Release number of selected component (if applicable):

cparg@crusty : $ dnf repolist
Paketquellen-ID                                                                               Paketquellen-Name:
appstream               CentOS Linux 8 - AppStream
baseos                  CentOS Linux 8 - BaseOS
epel                    Extra Packages for Enterprise Linux 8 - x86_64
epel-modular            Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                  CentOS Linux 8 - Extras
google-chrome           google-chrome
teams                   teams

cparg@crusty : $ lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-ia32:core-4.1-noarch
Distributor ID: CentOS
Description:    CentOS Linux release 8.4.2105
Release:        8.4.2105
Codename:       n/a

How reproducible:


Steps to Reproduce:
1. dnf install tesseract
2.
3.

Actual results:

$ dnf install tesseract

Letzte Prüfung auf abgelaufene Metadaten: vor 0:52:21 am Mi 14 Jul 2021 13:58:31 CEST.
Fehler: 
 Problem: conflicting requests
  - nothing provides liblept.so.5()(64bit) needed by tesseract-4.1.0-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:


Additional info:
I was not able to figure out the package maintainer, hence I filed this bug report here.

Comment 1 cparg 2021-07-14 12:59:45 UTC
Looks like this package should be retrieved from the "PowerTools" Repository.
I was under the impression that epel depends only on the OS base repository.

Comment 2 Fedora Update System 2021-07-14 13:28:34 UTC
FEDORA-EPEL-2021-d8b65a55a2 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-d8b65a55a2

Comment 3 Sandro Mani 2021-07-14 13:29:07 UTC
I've fired off a rebuild, check if it helps.

Comment 4 Fedora Update System 2021-07-15 01:13:06 UTC
FEDORA-EPEL-2021-d8b65a55a2 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-d8b65a55a2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 cparg 2021-07-25 08:14:01 UTC
Thanks for the re-build. However, as I stated earlier the problem was resolved adding the PowerTools repository. I didn't know that EPEL has dependencies on that repo.

Comment 6 Fedora Update System 2021-07-30 00:33:12 UTC
FEDORA-EPEL-2021-d8b65a55a2 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.