Bug 198230 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Guenther Deschner
David Lawrence
:
: 198231 (view as bug list)
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 11:12 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 06:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 11:12:49 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


samba-common-3.0.23-0.RC3
undefined symbol: yperr_string  (/usr/lib/libnss_wins.so)
undefined symbol: secrets_fetch_machine_password        (/usr/lib/libnss_wins.so)
undefined symbol: secrets_fetch (/usr/lib/libnss_wins.so)
undefined symbol: secrets_delete        (/usr/lib/libnss_wins.so)
undefined symbol: secrets_store (/usr/lib/libnss_wins.so)
undefined symbol: secrets_fetch_domain_sid      (/usr/lib/libnss_wins.so)
undefined symbol: yp_get_default_domain (/usr/lib/libnss_wins.so)
undefined symbol: yp_match      (/usr/lib/libnss_wins.so)
Comment 1 Guenther Deschner 2007-03-14 12:59:22 EDT
*** Bug 198231 has been marked as a duplicate of this bug. ***
Comment 2 Guenther Deschner 2007-04-03 10:06:04 EDT
Fixed upstream in 3_0 and also in 3_0_25, porting down the fix.

Note You need to log in before you can comment on or make changes to this bug.