Bug 198237 - ldd -r reports undefined symbols
ldd -r reports undefined symbols
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: readline (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: ldd-r-kh
  Show dependency treegraph
 
Reported: 2006-07-10 11:19 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 11:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-10 11:19:47 EDT
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


readline-devel-5.0-3.2.1
undefined symbol: BC    (/usr/lib/libreadline.so)
undefined symbol: PC    (/usr/lib/libreadline.so)
undefined symbol: UP    (/usr/lib/libreadline.so)
undefined symbol: tgetnum       (/usr/lib/libreadline.so)
undefined symbol: tgoto (/usr/lib/libreadline.so)
undefined symbol: tgetflag      (/usr/lib/libreadline.so)
undefined symbol: tputs (/usr/lib/libreadline.so)
undefined symbol: tgetent       (/usr/lib/libreadline.so)
undefined symbol: tgetstr       (/usr/lib/libreadline.so)
Comment 1 Tim Waugh 2006-07-10 11:23:16 EDT
Readline is a special case since there s more than one library that can satisfy
those symbols.

Note You need to log in before you can comment on or make changes to this bug.