Bug 19825 - remote print fails
remote print fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-25 14:44 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 21:46:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-25 14:44:18 EDT
Clean install of Red Hat 7 (identical hardware ran 6.2) cannot print to
networked HP Laser Jet 6.  Use printttool for config, set up same as before
as follows...

Remote Unix Printer
 name lp
 spool directory /var/spool/lpd/lp
 file limit 0
 myprinter.mynetwork.com
 input filter LaserJet4
 Send EOF, fix stair stepping, fast printing for non-PS

Printer is attached to an Axis 540 print server and has an IP assigned in
my subnet.  RH 6.2 server still prints to it like a champ, so it must be
something in the new print subsystem.  My printcap looks like...

##PRINTTOOL3## REMOTE ljet4 600x600 letter {} LaserJet4 Default 1
lp:\
	:sd=/var/spool/lpd/lp:\
	:mx#0:\
	:sh:\
	:rm=myprinter.mynetwork.com:\
	:rp=:\
	:lpd_bounce=true:\
	:if=/var/spool/lpd/lp/filter:

The output from /var/spool/lpd/lp/lpq looks like this when I attempt to
send a Post Script test page...


Printer: lp@m001065 (dest lp@myprinter.mynetwork.com)
 Queue: 1 printable job
 Server: pid 1242 active
 Unspooler: pid 1243 active
 Status: processing 'dfA241m001065.mynetwork.com', size 18043, format 'f',
IF filter 'filter' at 14:01:13.079
 Status: waiting for subserver to exit at 14:01:13.081
 Status: IF filter 'filter' filter finished at 14:01:13.666
 Status: printing finished at 14:01:13.667
 Status: sending job 'root@m001065+241' to lp@myprinter.mynetwork.com at
14:01:13.667
 Status: connecting to 'myprinter.mynetwork.com', attempt 1 at 14:01:13.667
 Status: connected to 'myprinter.mynetwork.com' at 14:01:13.682
 Status: requesting printer lp@myprinter.mynetwork.com at 14:01:13.682
 Status: job 'root@m001065+241' transfer to lp@myprinter.mynetwork.com
failed
 Status:   error 'NONZERO RFC1179 ERROR CODE FROM SERVER' with ack
'ACK_STOP_Q'
 Status:   sending str '^Blp' to lp@myprinter.mynetwork.com at 14:01:13.690
 Rank   Owner/ID                  Class Job Files                 Size Time
active root@m001065+241             A   241 /usr/lib/rhs/rhs-pri 18043
14:01:13

We have attempted to print to this printer from 3 different Red Hat 7 boxes
on our network, with 2 different NICs (Intel Ethernet Express Pro 10.100
and 3Com 905C integrated on a DELL/Intel 810 mobo) with similar results. 
Two of the machines have all of the latest patches from Red Hat including
the new LPRng stuff, so it does not appear to be anything there.  As stated
before, same printer still works like a champ from RH 6.2 so it's something
new subsystem, please advise.
Comment 1 Crutcher Dunnavant 2001-02-02 21:46:39 EST
If you are still having these problems, please try the following, and respond:

Try bouncing the 7.0 box's prints through a 6.2 box.

If that works, this may be an lpd extension issue, and as such, could be nasty
to fix.
Comment 2 Crutcher Dunnavant 2001-03-09 18:13:26 EST
if your are still having these problems, reopen.

try latest printing from:
http://people.redhat.com/crutcher/printing/

Note You need to log in before you can comment on or make changes to this bug.