Bug 1982611 - [aws] image-registry panics when the cluster is installed in a new region
Summary: [aws] image-registry panics when the cluster is installed in a new region
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.z
Assignee: Oleg Bulatov
QA Contact: wewang
URL:
Whiteboard:
Depends On: 1977159
Blocks: 1976198
TreeView+ depends on / blocked
 
Reported: 2021-07-15 09:48 UTC by Wenjing Zheng
Modified: 2021-08-25 13:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-25 13:49:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 706 0 None open Bug 1982611: bump aws-sdk-go to v1.38.35 2021-07-20 12:18:53 UTC
Github openshift image-registry pull 287 0 None open Bug 1982611: bump aws-sdk-go to v1.38.35 2021-07-20 12:14:09 UTC
Red Hat Product Errata RHBA-2021:3197 0 None None None 2021-08-25 13:49:34 UTC

Description Wenjing Zheng 2021-07-15 09:48:44 UTC
This bug was initially created as a copy of Bug #1977159

I am copying this bug because: 



This bug was initially created as a copy of Bug #1952610

I am copying this bug because: 



Description of problem:
When the cluster is installed in a new region that is unknown in the AWS SDK version being used, the image-registry pod crashes.


How reproducible:
100%


Steps to Reproduce:
1. Install a cluster in ap-northeast-3. Use custom endpoints for ec2 and elb so that the machine-api-operator can create the worker machines.
2. Note that the image-registry pods crashloop.

Actual results:
time="2021-04-22T16:34:48.852602706Z" level=info msg="start registry" distribution_version=v2.7.1+unknown go.version=go1.16.1 openshift_version=4.8.0-202104162013.p0-1b129a6
time="2021-04-22T16:34:48.853154564Z" level=info msg="caching project quota objects with TTL 1m0s" go.version=go1.16.1
panic: Invalid region provided: ap-northeast-3

goroutine 1 [running]:
github.com/docker/distribution/registry/handlers.NewApp(0x1ef27e8, 0xc000128010, 0xc0002c7880, 0xc0003934d0)
	/go/src/github.com/openshift/image-registry/vendor/github.com/docker/distribution/registry/handlers/app.go:127 +0x3133
github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware.NewApp(0x1ef27e8, 0xc000128010, 0xc0002c7880, 0x1efab98, 0xc000403200, 0x1efe100)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware/app.go:96 +0x87
github.com/openshift/image-registry/pkg/dockerregistry/server.NewApp(0x1ef27e8, 0xc000128010, 0x1ec6518, 0xc000550bc8, 0xc0002c7880, 0xc0000b20a0, 0x0, 0x0, 0xc0003920f0, 0xc00053f7c0)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/app.go:138 +0x2c5
github.com/openshift/image-registry/pkg/cmd/dockerregistry.NewServer(0x1ef27e8, 0xc000128010, 0xc0002c7880, 0xc0000b20a0, 0x0, 0x0, 0x1f142b8)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:210 +0x1ce
github.com/openshift/image-registry/pkg/cmd/dockerregistry.Execute(0x1eb9c40, 0xc0005509b8)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:164 +0xa65
main.main()
	/go/src/github.com/openshift/image-registry/cmd/dockerregistry/main.go:93 +0x573


Expected results:
The image-registry will accept the new region as it matches the regular expression for a region in the default AWS partition.

Comment 2 Oleg Bulatov 2021-07-24 20:36:11 UTC
PRs are awaiting review.

Comment 7 wewang 2021-08-06 08:17:23 UTC
Verified in version as below, Install a cluster in ap-northeast-3, image registry pods are running, no crashloop
Version:
4.6.0-0.nightly-2021-08-05-205045

Comment 10 errata-xmlrpc 2021-08-25 13:49:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.43 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3197


Note You need to log in before you can comment on or make changes to this bug.