Bug 198262 - svg file causes Nautilus to crash
svg file causes Nautilus to crash
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nautilus (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 14:16 EDT by Paul Kennedy
Modified: 2015-04-19 20:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 10:23:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
svg file (59.86 KB, image/svg+xml)
2006-07-10 14:16 EDT, Paul Kennedy
no flags Details

  None (edit)
Description Paul Kennedy 2006-07-10 14:16:34 EDT
Created attachment 132190 [details]
svg file
Comment 1 Paul Kennedy 2006-07-10 14:16:34 EDT
Description of problem:
Nautilus fails while opening a directory that contains an svg file. Typically,
Nautilus displays contents using "View as Icons" even though default chosen view
is "View as List" for my computer. When I attempt to change from "View as Icons"
to "View as List", the display freezes up. When that happens, I usually have to
go to console to kill nautilus to get access to my desktop. 

If I just wait, without trying to change view, then the  display just freezes
up, allowing me access to the desktop. Sometimes the error dialog box is displayed.

I first noticed the problem when the svg file was in /tmp from an attempt to
open the file with gthumb (which failed when it attempted to open the svg file).
When I removed the svg file from /tmp, no more problems. Reintroduced svg file
to /tmp and problem happened. Tried placing svg file in other directories--same
problem. 

The svg file (rhcs-basic-block-v4.svg) is attached to this bug.

Version-Release number of selected component (if applicable):
Nautilus 2.8.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Paul Kennedy 2006-07-13 10:23:05 EDT
From afitzsim:
This is a librsvg bug, not a nautilusa bug.  The issue is fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.